summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-16 09:16:02 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-16 10:52:52 +0100
commitbaea9e4db43c2ee0f0c3325db3684ca14fcf499d (patch)
tree4ec79d4457dea7b470057b976dbcf108e5656026 /dev-python/lz4/lz4-3.1.2.ebuild
parentdev-ml/ppx_deriving: remove old version (diff)
downloadgentoo-baea9e4db43c2ee0f0c3325db3684ca14fcf499d.tar.gz
gentoo-baea9e4db43c2ee0f0c3325db3684ca14fcf499d.tar.bz2
gentoo-baea9e4db43c2ee0f0c3325db3684ca14fcf499d.zip
dev-python/lz4: Bump to 3.1.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/lz4/lz4-3.1.2.ebuild')
-rw-r--r--dev-python/lz4/lz4-3.1.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/lz4/lz4-3.1.2.ebuild b/dev-python/lz4/lz4-3.1.2.ebuild
new file mode 100644
index 000000000000..c8473e470e6a
--- /dev/null
+++ b/dev-python/lz4/lz4-3.1.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="LZ4 Bindings for Python"
+HOMEPAGE="https://pypi.org/project/lz4/ https://github.com/python-lz4/python-lz4"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="app-arch/lz4:="
+DEPEND=${RDEPEND}
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/pkgconfig[${PYTHON_USEDEP}]
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest