summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger (asterix) <m.mairkeimberger@gmail.com>2017-08-08 10:25:22 +0200
committerDavid Seifert <soap@gentoo.org>2017-08-13 13:23:48 +0200
commite48e6a67c2bf03e4165d51f2793dc904f73faddb (patch)
treeb457809d21da75fadb53c7b9b0ca769561a61bf0 /dev-python/m2crypto/files
parentdev-python/jsonpickle: remove unused patches (diff)
downloadgentoo-e48e6a67c2bf03e4165d51f2793dc904f73faddb.tar.gz
gentoo-e48e6a67c2bf03e4165d51f2793dc904f73faddb.tar.bz2
gentoo-e48e6a67c2bf03e4165d51f2793dc904f73faddb.zip
dev-python/m2crypto: remove unused patches
Closes: https://github.com/gentoo/gentoo/pull/5352
Diffstat (limited to 'dev-python/m2crypto/files')
-rw-r--r--dev-python/m2crypto/files/0.22.3-Use-swig-generated-python-loader.patch138
-rw-r--r--dev-python/m2crypto/files/0.22.3-packaging.patch69
2 files changed, 0 insertions, 207 deletions
diff --git a/dev-python/m2crypto/files/0.22.3-Use-swig-generated-python-loader.patch b/dev-python/m2crypto/files/0.22.3-Use-swig-generated-python-loader.patch
deleted file mode 100644
index 9ddd5509fdf6..000000000000
--- a/dev-python/m2crypto/files/0.22.3-Use-swig-generated-python-loader.patch
+++ /dev/null
@@ -1,138 +0,0 @@
-From 803188070e486030cb1d2e53692b39305c742b17 Mon Sep 17 00:00:00 2001
-From: Joe Julian <jjulian@io.com>
-Date: Tue, 19 May 2015 23:54:08 -0700
-Subject: [PATCH] Use swig generated python loader
-
----
- .gitignore | 6 +++++-
- M2Crypto/__init__.py | 4 ++--
- M2Crypto/m2.py | 4 +---
- SWIG/_m2crypto.def | 2 +-
- SWIG/_m2crypto.i | 2 +-
- setup.py | 25 +++++++++++++++++++++----
- 6 files changed, 31 insertions(+), 12 deletions(-)
-
-diff --git a/M2Crypto/__init__.py b/M2Crypto/__init__.py
-index 647e057..38dbbd5 100644
---- a/M2Crypto/__init__.py
-+++ b/M2Crypto/__init__.py
-@@ -19,7 +19,7 @@ Copyright 2008-2011 Heikki Toivonen. All rights reserved.
- version_info = (0, 22)
- version = '.'.join([str(_v) for _v in version_info])
-
--import __m2crypto
-+import m2crypto
- import m2
- import ASN1
- import AuthCookie
-@@ -47,4 +47,4 @@ import m2xmlrpclib
- import threading
- import util
-
--__m2crypto.lib_init()
-+m2crypto.lib_init()
-diff --git a/M2Crypto/m2.py b/M2Crypto/m2.py
-index e4bb695..516cadb 100644
---- a/M2Crypto/m2.py
-+++ b/M2Crypto/m2.py
-@@ -25,7 +25,5 @@ Portions created by Open Source Applications Foundation (OSAF) are
- Copyright (C) 2004 OSAF. All Rights Reserved.
- """
-
--from __m2crypto import *
-+from m2crypto import *
- lib_init()
--
--
-diff --git a/SWIG/_m2crypto.def b/SWIG/_m2crypto.def
-index 753db2c..3e9d5bc 100644
---- a/SWIG/_m2crypto.def
-+++ b/SWIG/_m2crypto.def
-@@ -1,2 +1,2 @@
- EXPORTS
--init__m2crypto
-+init_m2crypto
-diff --git a/SWIG/_m2crypto.i b/SWIG/_m2crypto.i
-index 50be5c3..e491222 100644
---- a/SWIG/_m2crypto.i
-+++ b/SWIG/_m2crypto.i
-@@ -8,7 +8,7 @@
- *
- */
-
--%module(threads=1) _m2crypto
-+%module(threads=1) m2crypto
- /* We really don't need threadblock (PyGILState_Ensure() etc.) anywhere.
- Disable threadallow as well, only enable it for operations likely to
- block. */
-diff --git a/setup.py b/setup.py
-index bac6f9f..fc89513 100644
---- a/setup.py
-+++ b/setup.py
-@@ -17,9 +17,22 @@ import os, sys, platform
- from setuptools import setup
- from setuptools.command import build_ext
-
-+from distutils.util import get_platform
- from distutils.core import Extension
- from distutils.spawn import find_executable
-
-+from distutils.command.build import build
-+from setuptools.command.install import install
-+
-+class CustomBuild(build):
-+ def run(self):
-+ self.run_command('build_ext')
-+ build.run(self)
-+
-+class CustomInstall(install):
-+ def run(self):
-+ self.run_command('build_ext')
-+ self.do_egg_install()
-
- class _M2CryptoBuildExt(build_ext.build_ext):
- '''Specialization of build_ext to enable swig_opts to inherit any
-@@ -70,11 +83,12 @@ class _M2CryptoBuildExt(build_ext.build_ext):
-
- self.add_multiarch_paths()
-
-- opensslIncludeDir = os.path.join(self.openssl, 'include')
-+ includeDir = os.path.join(self.openssl, 'include')
-+ opensslIncludeDir = os.path.join(self.openssl, 'include', 'openssl')
- opensslLibraryDir = os.path.join(self.openssl, 'lib')
-
- self.swig_opts = ['-I%s' % i for i in self.include_dirs + \
-- [opensslIncludeDir, os.path.join(opensslIncludeDir, "openssl")]]
-+ [opensslIncludeDir, includeDir]]
- self.swig_opts.append('-includeall')
- self.swig_opts.append('-modern')
-
-@@ -85,6 +99,9 @@ class _M2CryptoBuildExt(build_ext.build_ext):
- elif platform.architecture()[0] == '32bit':
- self.swig_opts.append('-D__i386__')
-
-+ self.swig_opts.append('-outdir')
-+ self.swig_opts.append(os.path.join(os.getcwd(),'M2Crypto'))
-+
- self.include_dirs += [os.path.join(self.openssl, opensslIncludeDir),
- os.path.join(os.getcwd(), 'SWIG')]
-
-@@ -103,7 +120,7 @@ if sys.platform == 'darwin':
- else:
- my_extra_compile_args = []
-
--m2crypto = Extension(name = 'M2Crypto.__m2crypto',
-+m2crypto = Extension(name = 'M2Crypto._m2crypto',
- sources = ['SWIG/_m2crypto.i'],
- extra_compile_args = ['-DTHREADING'] + my_extra_compile_args,
- #extra_link_args = ['-Wl,-search_paths_first'], # Uncomment to build Universal Mac binaries
-@@ -145,5 +162,5 @@ interface.''',
-
- ext_modules = [m2crypto],
- test_suite='tests.alltests.suite',
-- cmdclass = {'build_ext': _M2CryptoBuildExt}
-+ cmdclass = {'build': CustomBuild, 'install': CustomInstall, 'build_ext': _M2CryptoBuildExt}
- )
---
-2.4.1
-
diff --git a/dev-python/m2crypto/files/0.22.3-packaging.patch b/dev-python/m2crypto/files/0.22.3-packaging.patch
deleted file mode 100644
index 26952a4e78e8..000000000000
--- a/dev-python/m2crypto/files/0.22.3-packaging.patch
+++ /dev/null
@@ -1,69 +0,0 @@
-From 0f2c82f097cf6d3722b7793fe1159160f3f52725 Mon Sep 17 00:00:00 2001
-From: Mike Gilbert <floppym@gentoo.org>
-Date: Mon, 25 May 2015 12:08:47 -0400
-Subject: [PATCH] Gentoo-specific packaging fixes
-
-Fix cross-compiles
-EPREFIX support
----
- setup.py | 20 ++++----------------
- 1 file changed, 4 insertions(+), 16 deletions(-)
-
-diff --git a/setup.py b/setup.py
-index fc89513..8360e7e 100644
---- a/setup.py
-+++ b/setup.py
-@@ -32,7 +32,7 @@ class CustomBuild(build):
- class CustomInstall(install):
- def run(self):
- self.run_command('build_ext')
-- self.do_egg_install()
-+ install.run(self)
-
- class _M2CryptoBuildExt(build_ext.build_ext):
- '''Specialization of build_ext to enable swig_opts to inherit any
-@@ -81,29 +81,19 @@ class _M2CryptoBuildExt(build_ext.build_ext):
-
- build_ext.build_ext.finalize_options(self)
-
-- self.add_multiarch_paths()
--
- includeDir = os.path.join(self.openssl, 'include')
- opensslIncludeDir = os.path.join(self.openssl, 'include', 'openssl')
- opensslLibraryDir = os.path.join(self.openssl, 'lib')
-
-- self.swig_opts = ['-I%s' % i for i in self.include_dirs + \
-- [opensslIncludeDir, includeDir]]
-+ eprefix = os.getenv('EPREFIX', '')
-+ self.swig_opts = ['-I' + eprefix + '/usr/include']
- self.swig_opts.append('-includeall')
- self.swig_opts.append('-modern')
-
-- # Fedora does hat tricks.
-- if platform.linux_distribution()[0] in ['Fedora', 'CentOS']:
-- if platform.architecture()[0] == '64bit':
-- self.swig_opts.append('-D__x86_64__')
-- elif platform.architecture()[0] == '32bit':
-- self.swig_opts.append('-D__i386__')
--
- self.swig_opts.append('-outdir')
- self.swig_opts.append(os.path.join(os.getcwd(),'M2Crypto'))
-
-- self.include_dirs += [os.path.join(self.openssl, opensslIncludeDir),
-- os.path.join(os.getcwd(), 'SWIG')]
-+ self.include_dirs += [os.path.join(os.getcwd(), 'SWIG')]
-
- if sys.platform == 'cygwin':
- # Cygwin SHOULD work (there's code in distutils), but
-@@ -113,8 +103,6 @@ class _M2CryptoBuildExt(build_ext.build_ext):
- # Someday distutils will be fixed and this won't be needed.
- self.library_dirs += [os.path.join(self.openssl, 'bin')]
-
-- self.library_dirs += [os.path.join(self.openssl, opensslLibraryDir)]
--
- if sys.platform == 'darwin':
- my_extra_compile_args = ["-Wno-deprecated-declarations"]
- else:
---
-2.4.1
-