summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-27 21:57:47 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-27 22:05:29 +0100
commiteceb5aa9e5bb4c52e0b92267132432a495cae2f3 (patch)
tree94efe778d05d14d5e0d11d7db8e337c53ff11824 /dev-python/m2r/m2r-0.1.14.ebuild
parentdev-python/loguru: Remove redundant versions (diff)
downloadgentoo-eceb5aa9e5bb4c52e0b92267132432a495cae2f3.tar.gz
gentoo-eceb5aa9e5bb4c52e0b92267132432a495cae2f3.tar.bz2
gentoo-eceb5aa9e5bb4c52e0b92267132432a495cae2f3.zip
dev-python/m2r: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/m2r/m2r-0.1.14.ebuild')
-rw-r--r--dev-python/m2r/m2r-0.1.14.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/dev-python/m2r/m2r-0.1.14.ebuild b/dev-python/m2r/m2r-0.1.14.ebuild
deleted file mode 100644
index a0b987240484..000000000000
--- a/dev-python/m2r/m2r-0.1.14.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{6,7})
-
-inherit distutils-r1
-
-DESCRIPTION="Markdown to reStructuredText converter"
-HOMEPAGE="https://github.com/miyakogi/m2r https://pypi.org/project/m2r/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/mistune[${PYTHON_USEDEP}]
- dev-python/docutils[${PYTHON_USEDEP}]
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7)
- dev-python/pygments[${PYTHON_USEDEP}]
- )
- ${RDEPEND}
-"
-
-#S=${WORKDIR}/${P}
-
-python_prepare_all() {
- # fix a Q/A violation, trying to install the tests as an independant package
- sed -e "s/packages=\['tests'\],/packages=[],/" -i setup.py
- # add missing test files
- cp "${FILESDIR}/"test.md tests/ || die
- cp "${FILESDIR}/"test.rst tests/ || die
- cp "${FILESDIR}/"m2r.1 ./ || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- py.test -v || die "Tests failed with ${EPYTHON}"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- doman m2r.1
-}