summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-09 07:45:20 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-09 10:22:49 +0300
commit4c8431ca095bab33e3d5b6e6f943da3d33c86709 (patch)
tree958d1c56d6e5031d44109178baf747752d04e974 /dev-python/makefun
parentapp-admin/awscli: add 1.25.70 (diff)
downloadgentoo-4c8431ca095bab33e3d5b6e6f943da3d33c86709.tar.gz
gentoo-4c8431ca095bab33e3d5b6e6f943da3d33c86709.tar.bz2
gentoo-4c8431ca095bab33e3d5b6e6f943da3d33c86709.zip
dev-python/makefun: add 1.15.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/makefun')
-rw-r--r--dev-python/makefun/Manifest1
-rw-r--r--dev-python/makefun/makefun-1.15.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/makefun/Manifest b/dev-python/makefun/Manifest
index dd63d8aca6e2..793bd80e25e1 100644
--- a/dev-python/makefun/Manifest
+++ b/dev-python/makefun/Manifest
@@ -1 +1,2 @@
DIST makefun-1.14.0.tar.gz 73792 BLAKE2B 8a3f947d53787efc1be6d76c4c817063a21d0e135815d196988aa2c6d1e0998344010dfd1e2f33f31c0d47fcad8b7e4c0c7c9e408bdd3ea60f668c3ec8ae09dd SHA512 49b239a559e0ec5e28c29c210161c3530e1d89b39a22f16382f0569a47a6d696917d86c9abefb7ac6dc59f904276f8a853a2dc09b1d9c2332e422757f6eb9a08
+DIST makefun-1.15.0.tar.gz 74404 BLAKE2B b35ff14d46d50031ed42a13154c82f3fbe4105179c587dacebc0773a0d0be613e9858d57f497b8d710d7571f55230fc644592e6df67799736b37867feeb09b2e SHA512 067bd6a4176196a3aa4e96b7d460e45479cbd86d1cc611f1716fb8d1cdc17491e56f5676d7a287006ed8b80471dd28f5f48cb2eb8c1893883e3308ed9347fbae
diff --git a/dev-python/makefun/makefun-1.15.0.ebuild b/dev-python/makefun/makefun-1.15.0.ebuild
new file mode 100644
index 000000000000..e3a751264de5
--- /dev/null
+++ b/dev-python/makefun/makefun-1.15.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Small library to dynamically create Python functions"
+HOMEPAGE="
+ https://pypi.org/project/makefun/
+ https://github.com/smarie/python-makefun/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e '/pytest-runner/d' -i setup.cfg || die
+ distutils-r1_src_prepare
+}