summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2021-08-07 12:32:30 +0200
committerLouis Sautier <sbraz@gentoo.org>2021-08-07 13:17:19 +0200
commit0895f0b79cf9101cb9d5d80bd0d6965bdc453794 (patch)
tree880d6674d1a669a4e82ef06c8882bbaa5d260470 /dev-python/mamba
parentdev-ruby/yard: cleanup (diff)
downloadgentoo-0895f0b79cf9101cb9d5d80bd0d6965bdc453794.tar.gz
gentoo-0895f0b79cf9101cb9d5d80bd0d6965bdc453794.tar.bz2
gentoo-0895f0b79cf9101cb9d5d80bd0d6965bdc453794.zip
dev-python/mamba: add 0.11.2, enable py310
Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/mamba')
-rw-r--r--dev-python/mamba/Manifest1
-rw-r--r--dev-python/mamba/mamba-0.11.2.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/mamba/Manifest b/dev-python/mamba/Manifest
index 9b889a6dd2d9..f54cc2b9b028 100644
--- a/dev-python/mamba/Manifest
+++ b/dev-python/mamba/Manifest
@@ -1 +1,2 @@
DIST mamba-0.11.1.tar.gz 36974 BLAKE2B 0bffac92c32413be736c20f926094cd2003c8bd8abb47abda7c63a071af5b99729f32b5cdb74f21f30f0b50be81674f08f79dc37416e8c67e2ae03c9a837eda4 SHA512 2b28415e5352fcec8028a8ddef6ff83a0cf2ebbb385506eb97f6a46be619277136a61180e8cf30047efd7807f867a03a0d1032dbfed27e2fc050a8639f67814c
+DIST mamba-0.11.2.tar.gz 37370 BLAKE2B 90228aa9668c5c79161aee79d92a9409e5df5d9d71b94f2ae8401ec5eea32ed45cf1b1a72eb596b6e24f140bf053bca4cec848830ae83c24b108ddb4a2bcd148 SHA512 8ca6207c9df7b3388db8ecabd13456e54d8811c24f695ccc638c90bb2c975268f9e803533808f9b099651ee4744376fad3b58eaa84a6c97605631368f979915c
diff --git a/dev-python/mamba/mamba-0.11.2.ebuild b/dev-python/mamba/mamba-0.11.2.ebuild
new file mode 100644
index 000000000000..805822665e73
--- /dev/null
+++ b/dev-python/mamba/mamba-0.11.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python test runner born under the banner of Behavior Driven Development"
+HOMEPAGE="https://nestorsalceda.github.io/mamba"
+SRC_URI="https://github.com/nestorsalceda/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/clint-0.3.1[${PYTHON_USEDEP}]
+ >=dev-python/coverage-3.7.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ >=dev-python/doublex-expects-0.7.0_rc1[${PYTHON_USEDEP}]
+ >=dev-python/expects-0.8.0_rc2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs --no-autodoc
+
+python_test() {
+ "${EPYTHON}" -m mamba.cli || die "Tests failed under ${EPYTHON}"
+}