summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-03-02 00:18:06 +0100
committerPatrick Lauer <patrick@gentoo.org>2016-03-02 00:19:55 +0100
commit26ea049bee1f04e4b6b15e6ee59fdb5fb05ab103 (patch)
tree7a1740377c8d498339eb2c5dba86e2b2019c84a2 /dev-python/mantissa/mantissa-0.8.4.ebuild
parentsci-astronomy/astrometry: Initial import (major bump from science overlay) (diff)
downloadgentoo-26ea049bee1f04e4b6b15e6ee59fdb5fb05ab103.tar.gz
gentoo-26ea049bee1f04e4b6b15e6ee59fdb5fb05ab103.tar.bz2
gentoo-26ea049bee1f04e4b6b15e6ee59fdb5fb05ab103.zip
dev-python/mantissa: Bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-python/mantissa/mantissa-0.8.4.ebuild')
-rw-r--r--dev-python/mantissa/mantissa-0.8.4.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/mantissa/mantissa-0.8.4.ebuild b/dev-python/mantissa/mantissa-0.8.4.ebuild
new file mode 100644
index 000000000000..2988aec09008
--- /dev/null
+++ b/dev-python/mantissa/mantissa-0.8.4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit twisted-r1
+
+MY_PN="${PN/m/M}"
+DESCRIPTION="An extensible, multi-protocol, multi-user, interactive application server"
+HOMEPAGE="https://github.com/twisted/mantissa"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/pyopenssl-0.13[${PYTHON_USEDEP}]
+ >=dev-python/axiom-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/cssutils-0.9.5[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ >=dev-python/nevow-0.9.5[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2012j[${PYTHON_USEDEP}]
+ >=dev-python/twisted-core-14.0.0[${PYTHON_USEDEP}]
+ >=dev-python/twisted-mail-14.0.0[${PYTHON_USEDEP}]
+ >=dev-python/twisted-conch-14.0.0[${PYTHON_USEDEP}]
+ >=dev-python/vertex-0.2[${PYTHON_USEDEP}]
+ dev-python/pycrypto[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )"
+
+TWISTED_PLUGINS=( axiom.plugins nevow.plugins xmantissa.plugins )
+
+python_test() {
+ # https://github.com/twisted/mantissa/issues/27
+
+ trial xmantissa || die "tests failed with ${EPYTHON}"
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ # remove foreign caches we don't want to own
+ find "${D}$(python_get_sitedir)" -name 'dropin.cache' -delete || die
+ # then our own one
+ touch "${D}$(python_get_sitedir)"/xmantissa/plugins/dropin.cache || die
+}