summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/manuel/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/manuel/files')
-rw-r--r--dev-python/manuel/files/manuel-1.7-rm_zope_test.patch92
1 files changed, 92 insertions, 0 deletions
diff --git a/dev-python/manuel/files/manuel-1.7-rm_zope_test.patch b/dev-python/manuel/files/manuel-1.7-rm_zope_test.patch
new file mode 100644
index 000000000000..3487e5f9a9fa
--- /dev/null
+++ b/dev-python/manuel/files/manuel-1.7-rm_zope_test.patch
@@ -0,0 +1,92 @@
+diff -ur manuel-1.7.1.orig/src/manuel/tests.py manuel-1.7.1/src/manuel/tests.py
+--- src/manuel/tests.py 2012-04-17 03:08:54.000000000 +0800
++++ src/manuel/tests.py 2012-05-21 20:43:20.981722893 +0800
+@@ -9,16 +9,17 @@
+ import os.path
+ import re
+ import unittest
+-import zope.testing.renormalizing
+
+ doctest = manuel.absolute_import('doctest')
+
+ here = os.path.dirname(os.path.abspath(__file__))
+
+-checker = zope.testing.renormalizing.RENormalizing([
++try:
++ checker = zope.testing.renormalizing.RENormalizing([
+ (re.compile(r"<unittest\.result\.TestResult"), '<unittest.TestResult'),
+ ])
+-
++except:
++ pass
+
+ def turtle_on_the_bottom_test():
+ """We use manuel to test itself.
+@@ -52,7 +53,6 @@
+ optionflags = doctest.NORMALIZE_WHITESPACE | doctest.ELLIPSIS
+
+ m = manuel.ignore.Manuel()
+- m += manuel.doctest.Manuel(optionflags=optionflags, checker=checker)
+ m += manuel.codeblock.Manuel()
+ m += manuel.capture.Manuel()
+ m += manuel.testcase.SectionManuel()
+@@ -66,3 +66,6 @@
+ suite,
+ doctest.DocTestSuite(),
+ ))
++
++if __name__ == '__main__':
++ unittest.TextTestRunner().run(test_suite())
+diff -ur manuel-1.7.1.orig/setup.py manuel-1.7.1/setup.py
+--- setup.py 2013-02-14 10:07:38.000000000 +0800
++++ setup.py 2013-03-15 23:21:18.834849031 +0800
+@@ -21,8 +21,6 @@
+ + open('CHANGES.txt').read()
+ )
+
+-tests_require = ['zope.testing']
+-
+ setup(
+ name='manuel',
+ version='1.7.1',
+@@ -38,10 +36,6 @@
+ 'Programming Language :: Python :: 3',
+ ],
+ license='ZPL',
+- extras_require={
+- 'tests': tests_require,
+- },
+- tests_require = tests_require,
+ test_suite = 'manuel.tests.test_suite',
+ install_requires=[
+ 'setuptools',
+diff -ur manuel-1.7.1.orig/src/manuel/index.txt manuel-1.7.1/src/manuel/index.txt
+--- src/manuel/index.txt 2012-04-17 03:08:54.000000000 +0800
++++ src/manuel/index.txt 2012-04-28 05:43:26.918993769 +0800
+@@ -166,16 +166,16 @@
+
+ .. code-block:: python
+
+- import os.path
+- import manuel.testing
++ import os.path
++ import manuel.testing
+
+- class StripDirsTestCase(manuel.testing.TestCase):
+- def shortDescription(self):
++ class StripDirsTestCase(manuel.testing.TestCase):
++ def shortDescription(self):
+ return os.path.basename(str(self))
+- suite = manuel.testing.TestSuite(
+- m, path_to_test, TestCase=StripDirsTestCase)
++ suite = manuel.testing.TestSuite(
++ m, path_to_test, TestCase=StripDirsTestCase)
+
+- >>> list(suite)[0].shortDescription()
++ list(suite)[0].shortDescription()
+ 'bugs.txt'
+
+
+
+
+