summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-03 09:10:54 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-03 10:09:14 +0100
commitde4d0920c8b3b9694a1bb56548af7f16323e4edf (patch)
tree7e7ba4163b529a0185a1334ceebd1496b90ffcad /dev-python/mapbox_earcut/mapbox_earcut-1.0.1.ebuild
parentdev-python/pyupgrade: Bump to 3.3.0 (diff)
downloadgentoo-de4d0920c8b3b9694a1bb56548af7f16323e4edf.tar.gz
gentoo-de4d0920c8b3b9694a1bb56548af7f16323e4edf.tar.bz2
gentoo-de4d0920c8b3b9694a1bb56548af7f16323e4edf.zip
dev-python/mapbox_earcut: Bump to 1.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/mapbox_earcut/mapbox_earcut-1.0.1.ebuild')
-rw-r--r--dev-python/mapbox_earcut/mapbox_earcut-1.0.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/mapbox_earcut/mapbox_earcut-1.0.1.ebuild b/dev-python/mapbox_earcut/mapbox_earcut-1.0.1.ebuild
new file mode 100644
index 000000000000..6177d2e7c7bd
--- /dev/null
+++ b/dev-python/mapbox_earcut/mapbox_earcut-1.0.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+MY_P="mapbox_earcut_python-${PV}"
+DESCRIPTION="Python bindings to the mapbox earcut C++ library"
+HOMEPAGE="https://github.com/skogler/mapbox_earcut_python"
+SRC_URI="
+ https://github.com/skogler/mapbox_earcut_python/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/pybind11[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+DOCS=( CHANGELOG.md README.md )