summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/markdown
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/markdown')
-rw-r--r--dev-python/markdown/Manifest3
-rw-r--r--dev-python/markdown/files/markdown-2.2.0-tests.patch80
-rw-r--r--dev-python/markdown/markdown-2.5.1.ebuild45
-rw-r--r--dev-python/markdown/markdown-2.6.1.ebuild45
-rw-r--r--dev-python/markdown/markdown-2.6.2.ebuild48
-rw-r--r--dev-python/markdown/metadata.xml11
6 files changed, 232 insertions, 0 deletions
diff --git a/dev-python/markdown/Manifest b/dev-python/markdown/Manifest
new file mode 100644
index 000000000000..43a78c806205
--- /dev/null
+++ b/dev-python/markdown/Manifest
@@ -0,0 +1,3 @@
+DIST Markdown-2.5.1.tar.gz 288970 SHA256 8f81ed12c18608a502828acb7d318f362c42f4eca97d01e93cadfc52c1e40b73 SHA512 27f0d3909d6aa1e0ae15403da1cdfafcbfd463d7a236e0ea0cf02c55efa8f863c2554d54e20b0d9f58d80502dbf333120431474f16c64883001e5a318866eeb0 WHIRLPOOL 88f76fcb744ad6b8429442de409275c655a85039475d6dab11031a141e148286cc56d7865f590b432bfcf91af4965963989dae9a68a01e6931f367f425f83420
+DIST Markdown-2.6.1.tar.gz 298074 SHA256 b5879b87e8e5c125c92ab8c8f3babce78ad4e840446eed73c5b6e2984648d2b1 SHA512 53e11c5d4feacdb8210427da65b6b09453e8c904e86b42095a80132a4b67e926ba974458769e5227bfeaddd3bba5f6bd7ca7e3385951982ec982f63989119d78 WHIRLPOOL 58b6d87354ee19aac7ad1567e10f2cdc99c1aa980d3bee2fee81a5ccb5e70f43d13750dfaf1df9a42c00f3d35664731b52bfa1246271907f5a3422281ede1cc6
+DIST Markdown-2.6.2.tar.gz 298231 SHA256 ee17d0d7dc091e645dd48302a2e21301cc68f188505c2069d8635f94554170bf SHA512 a69dabf65187f54d200f59191a149bfe2109f94ffc5d003e15c2e6333c0b5fdeebfc4136842d7be5a15bc903b7a22120a4ccba2722858194c43fd09cd8fbea16 WHIRLPOOL a3c74f150e6e140b0b0500d0694b89b8e6836adef66cd2c14a1ad5ff8d4dc202b35fae8a0c9683e53030fc80792885cd4b22c46729963a683ebbbb5101963dd7
diff --git a/dev-python/markdown/files/markdown-2.2.0-tests.patch b/dev-python/markdown/files/markdown-2.2.0-tests.patch
new file mode 100644
index 000000000000..ef05702c643b
--- /dev/null
+++ b/dev-python/markdown/files/markdown-2.2.0-tests.patch
@@ -0,0 +1,80 @@
+https://github.com/waylan/Python-Markdown/issues/112
+https://github.com/waylan/Python-Markdown/commit/5b3e724fb78da73ab87fb34e4ac9d9299773cfed
+
+--- markdown/__init__.py
++++ markdown/__init__.py
+@@ -37,6 +37,7 @@
+ import codecs
+ import sys
+ import logging
++import warnings
+ import util
+ from preprocessors import build_preprocessors
+ from blockprocessors import build_block_parser
+@@ -163,10 +164,10 @@
+ if isinstance(ext, basestring):
+ ext = self.build_extension(ext, configs.get(ext, []))
+ if isinstance(ext, Extension):
+- # might raise NotImplementedError, but that's the extension author's problem
+ ext.extendMarkdown(self, globals())
+ elif ext is not None:
+- raise ValueError('Extension "%s.%s" must be of type: "markdown.Extension".' \
++ raise TypeError(
++ 'Extension "%s.%s" must be of type: "markdown.Extension"'
+ % (ext.__class__.__module__, ext.__class__.__name__))
+
+ return self
+@@ -200,19 +201,22 @@
+ module_name_old_style = '_'.join(['mdx', ext_name])
+ try: # Old style (mdx_<extension>)
+ module = __import__(module_name_old_style)
+- except ImportError:
+- logger.warn("Failed loading extension '%s' from '%s' or '%s'"
+- % (ext_name, module_name, module_name_old_style))
+- # Return None so we don't try to initiate none-existant extension
+- return None
++ except ImportError, e:
++ message = "Failed loading extension '%s' from '%s' or '%s'" \
++ % (ext_name, module_name, module_name_old_style)
++ e.args = (message,) + e.args[1:]
++ raise
+
+ # If the module is loaded successfully, we expect it to define a
+ # function called makeExtension()
+ try:
+ return module.makeExtension(configs.items())
+ except AttributeError, e:
+- logger.warn("Failed to initiate extension '%s': %s" % (ext_name, e))
+- return None
++ message = e.args[0]
++ message = "Failed to initiate extension " \
++ "'%s': %s" % (ext_name, message)
++ e.args = (message,) + e.args[1:]
++ raise
+
+ def registerExtension(self, extension):
+ """ This gets called by the extension """
+--- tests/test_apis.py
++++ tests/test_apis.py
+@@ -245,18 +245,18 @@
+
+ def testLoadExtensionFailure(self):
+ """ Test failure of an extension to load. """
+- self.assertRaises(ValueError,
++ self.assertRaises(ImportError,
+ markdown.Markdown, extensions=['non_existant_ext'])
+
+ def testLoadBadExtension(self):
+ """ Test loading of an Extension with no makeExtension function. """
+ _create_fake_extension(name='fake', has_factory_func=False)
+- self.assertRaises(ValueError, markdown.Markdown, extensions=['fake'])
++ self.assertRaises(AttributeError, markdown.Markdown, extensions=['fake'])
+
+ def testNonExtension(self):
+ """ Test loading a non Extension object as an extension. """
+ _create_fake_extension(name='fake', is_wrong_type=True)
+- self.assertRaises(ValueError, markdown.Markdown, extensions=['fake'])
++ self.assertRaises(TypeError, markdown.Markdown, extensions=['fake'])
+
+ def testBaseExtention(self):
+ """ Test that the base Extension class will raise NotImplemented. """
diff --git a/dev-python/markdown/markdown-2.5.1.ebuild b/dev-python/markdown/markdown-2.5.1.ebuild
new file mode 100644
index 000000000000..1eec1250953c
--- /dev/null
+++ b/dev-python/markdown/markdown-2.5.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+
+inherit distutils-r1
+
+MY_PN="Markdown"
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Python implementation of the markdown markup language"
+HOMEPAGE="http://www.freewisdom.org/projects/python-markdown http://pypi.python.org/pypi/Markdown"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="|| ( BSD GPL-2 )"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ia64 ppc sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc test pygments"
+
+DEPEND="test? ( dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}] )"
+# source cites pytidylib however from testruns it appears optional
+RDEPEND="pygments? ( dev-python/pygments[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_compile_all() {
+ use doc && esetup.py build_docs
+}
+
+python_test() {
+ cp -r -l run-tests.py tests "${BUILD_DIR}"/ || die
+ pushd "${BUILD_DIR}" > /dev/null
+ "${PYTHON}" run-tests.py || die "Tests fail with ${EPYTHON}"
+ popd > /dev/null
+}
+
+python_install_all() {
+ # make use doc do a doc build
+ use doc && local HTML_DOCS=( "${BUILD_DIR}"/docs/. )
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/markdown/markdown-2.6.1.ebuild b/dev-python/markdown/markdown-2.6.1.ebuild
new file mode 100644
index 000000000000..482fedce7ff8
--- /dev/null
+++ b/dev-python/markdown/markdown-2.6.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+
+inherit distutils-r1
+
+MY_PN="Markdown"
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Python implementation of the markdown markup language"
+HOMEPAGE="http://www.freewisdom.org/projects/python-markdown http://pypi.python.org/pypi/Markdown"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="|| ( BSD GPL-2 )"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc test pygments"
+
+DEPEND="test? ( dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}] )"
+# source cites pytidylib however from testruns it appears optional
+RDEPEND="pygments? ( dev-python/pygments[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_compile_all() {
+ use doc && esetup.py build_docs
+}
+
+python_test() {
+ cp -r -l run-tests.py tests "${BUILD_DIR}"/ || die
+ pushd "${BUILD_DIR}" > /dev/null
+ "${PYTHON}" run-tests.py || die "Tests fail with ${EPYTHON}"
+ popd > /dev/null
+}
+
+python_install_all() {
+ # make use doc do a doc build
+ use doc && local HTML_DOCS=( "${BUILD_DIR}"/docs/. )
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/markdown/markdown-2.6.2.ebuild b/dev-python/markdown/markdown-2.6.2.ebuild
new file mode 100644
index 000000000000..c66101e15448
--- /dev/null
+++ b/dev-python/markdown/markdown-2.6.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy pypy3 )
+
+inherit distutils-r1
+
+MY_PN="Markdown"
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Python implementation of the markdown markup language"
+HOMEPAGE="http://www.freewisdom.org/projects/python-markdown http://pypi.python.org/pypi/Markdown"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="|| ( BSD GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc test pygments"
+
+DEPEND="
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )"
+# source cites pytidylib however from testruns it appears optional
+RDEPEND="pygments? ( dev-python/pygments[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_compile_all() {
+ use doc && esetup.py build_docs
+}
+
+python_test() {
+ cp -r -l run-tests.py tests "${BUILD_DIR}"/ || die
+ cd "${BUILD_DIR}" || die
+ "${PYTHON}" run-tests.py || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ # make use doc do a doc build
+ use doc && local HTML_DOCS=( "${BUILD_DIR}"/docs/. )
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/markdown/metadata.xml b/dev-python/markdown/metadata.xml
new file mode 100644
index 000000000000..46571022df6a
--- /dev/null
+++ b/dev-python/markdown/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <use>
+ <flag name="pygments">Enable fancy pygments support</flag>
+ </use>
+ <upstream>
+ <remote-id type="pypi">Markdown</remote-id>
+ </upstream>
+</pkgmetadata>