summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-06 22:00:03 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-06 22:13:32 +0200
commit5cde0a1100b0ea4085354fd166a72e7636a04ee3 (patch)
treece25bd84303ebc176613744805ae9c38f4440c85 /dev-python/markups
parentdev-python/hypothesis: Bump to 6.18.0 (diff)
downloadgentoo-5cde0a1100b0ea4085354fd166a72e7636a04ee3.tar.gz
gentoo-5cde0a1100b0ea4085354fd166a72e7636a04ee3.tar.bz2
gentoo-5cde0a1100b0ea4085354fd166a72e7636a04ee3.zip
dev-python/markups: Bump to 3.1.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/markups')
-rw-r--r--dev-python/markups/Manifest1
-rw-r--r--dev-python/markups/markups-3.1.2.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/markups/Manifest b/dev-python/markups/Manifest
index 2cd1ba0f82bf..38a5bb2fbf1b 100644
--- a/dev-python/markups/Manifest
+++ b/dev-python/markups/Manifest
@@ -1 +1,2 @@
DIST Markups-3.1.1.tar.gz 20482 BLAKE2B 26fb19e11aaede8eeadc5a3022785dd3663e7002c5fc4b17c3718d68bda55a9cba07fc1c83a78ca4dee06b4e911b74701fe11865e8933a9d385d032fac00eb0d SHA512 9e8e7b3cc86127fed0367faf257d761e0eae4ca5e11a9ddc8e99b2fc88c76ddb218ee371added56e2c19f5772754adc4c01a09503c308220f6a9d35e736220d7
+DIST Markups-3.1.2.tar.gz 20608 BLAKE2B 01f5e740b4d26c4a8c611070b0ffb879009cc241bd320f257d266e57f9f35becd728a45f1bbff98eb066c24abfb21a84c36d07814e0f54550c259c62fd48dbdb SHA512 5374c6c80eb71b4190af4c3ba47ec46fe7a92739d72feb023a571488dde6fdc377e98f2e24bc0c4e6cb7b4aa3b0f8aea90befa93e301cf6b02fcc4856affbceb
diff --git a/dev-python/markups/markups-3.1.2.ebuild b/dev-python/markups/markups-3.1.2.ebuild
new file mode 100644
index 000000000000..e1fcc46d0471
--- /dev/null
+++ b/dev-python/markups/markups-3.1.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+MY_P=${P^}
+DESCRIPTION="A wrapper around various text markups"
+HOMEPAGE="
+ https://pymarkups.readthedocs.io/en/latest/
+ https://github.com/retext-project/pymarkups
+ https://pypi.org/project/Markups/
+"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${PN^}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/markdown[${PYTHON_USEDEP}]
+ dev-python/python-markdown-math[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ app-text/pytextile[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/pymdown-extensions[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest