summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2019-08-23 20:16:18 -0700
committerZac Medico <zmedico@gentoo.org>2019-08-23 20:16:18 -0700
commit0902d13b3d1e5e3e103261a90a4ddff94f8f548e (patch)
treefd8d319c3f335ffccad405f06f966cf26c396b59 /dev-python/marshmallow
parentdev-python/marshmallow: Bump to version 2.20.2 (diff)
downloadgentoo-0902d13b3d1e5e3e103261a90a4ddff94f8f548e.tar.gz
gentoo-0902d13b3d1e5e3e103261a90a4ddff94f8f548e.tar.bz2
gentoo-0902d13b3d1e5e3e103261a90a4ddff94f8f548e.zip
dev-python/marshmallow: Bump to version 3.0.1
Package-Manager: Portage-2.3.72, Repoman-2.3.17 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'dev-python/marshmallow')
-rw-r--r--dev-python/marshmallow/Manifest1
-rw-r--r--dev-python/marshmallow/marshmallow-3.0.1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/marshmallow/Manifest b/dev-python/marshmallow/Manifest
index f89b767260bd..528b8635bb2b 100644
--- a/dev-python/marshmallow/Manifest
+++ b/dev-python/marshmallow/Manifest
@@ -1,3 +1,4 @@
DIST marshmallow-2.20.2.tar.gz 152437 BLAKE2B 0d31537051c45bad52d922439d1cb9d69fc4a4bc2767d6a13bfe32a9edc978cadf9b1c508ae51532f5661291f32ed4b7c5e54f5fcd092eb4ebd7d3045521e9b8 SHA512 05511aafa978377152ea8ea1b70dd5558782bf634df5ae52453bfa65c7ec9270a12cd7a32e11872808a3289cfab2ef0380e129e84878511872e7cc95b0792453
DIST marshmallow-3.0.0b12.tar.gz 153870 BLAKE2B 4279bb477861cbcef219a7442ffa29cb1f5bb084b08a9812256898771560add3d8e5dbcd2348d8734c1701131e02f33c69ca17f2d1d9010712e11ada96e0374f SHA512 3155503630b2a85eeb4b04769de79346b334975ab3611695806e799a76dfca78cc3c7d490b18158c757dd15d550fa408b651fa4c69b3e5eb147c4cf38613e2ab
DIST marshmallow-3.0.0b8.tar.gz 148882 BLAKE2B a83e9cb2ff7d5786e5a0d5c947e578f81d7d2ab008257df195096e06031b100cd6d31bdab3df63b6ab6704268b1915827dd89f7e5fce6a638d136686fc9ebc07 SHA512 34f7a974872d0cdad828e342788269ab19194e17f30716dc8db21bc3b86ab3f1be6bd5e31c7bcbeaad7b8c70acc39eab256eb938060eff42067f5f1b3ba51c1c
+DIST marshmallow-3.0.1.tar.gz 168186 BLAKE2B 6c89fed45c144a855c692bee39390e1c80b2977274acb704095e76567e6ed00643704473f95abac7fabb4c1d1d96b90cb9a6fe3a127a09a0d2a4c72c02358baf SHA512 085a7e9b265bb86232222e4decb32fa172d62bca3ba3c5303f12715be1b0ab6553b1978e28db520a6a7a25778915c770ac83c607bdebf5e4d26746cd69f2d555
diff --git a/dev-python/marshmallow/marshmallow-3.0.1.ebuild b/dev-python/marshmallow/marshmallow-3.0.1.ebuild
new file mode 100644
index 000000000000..7421ff3b53a4
--- /dev/null
+++ b/dev-python/marshmallow/marshmallow-3.0.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A lightweight library for converting complex datatypes to and from native Python datatypes."
+HOMEPAGE="https://github.com/marshmallow-code/marshmallow/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ )"
+
+src_prepare() {
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ py.test -v || die "tests failed under ${EPYTHON}"
+}