summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2019-12-13 00:27:28 +0300
committerAlexey Shvetsov <alexxy@gentoo.org>2019-12-13 00:27:28 +0300
commit297e8936d7f36a6d0f478ded996f24ae747821a7 (patch)
treee4870c1f11fe8b394644fd45551bcbbf6fc19df7 /dev-python/marshmallow
parentsys-libs/libunwind: remove unused patches (diff)
downloadgentoo-297e8936d7f36a6d0f478ded996f24ae747821a7.tar.gz
gentoo-297e8936d7f36a6d0f478ded996f24ae747821a7.tar.bz2
gentoo-297e8936d7f36a6d0f478ded996f24ae747821a7.zip
dev-python/marshmallow: Add 2.20.5 as dep for platformio
Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org>
Diffstat (limited to 'dev-python/marshmallow')
-rw-r--r--dev-python/marshmallow/Manifest1
-rw-r--r--dev-python/marshmallow/marshmallow-2.20.5.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/marshmallow/Manifest b/dev-python/marshmallow/Manifest
index aa40c00867c0..c30618831c6c 100644
--- a/dev-python/marshmallow/Manifest
+++ b/dev-python/marshmallow/Manifest
@@ -1,2 +1,3 @@
DIST marshmallow-2.20.2.tar.gz 152437 BLAKE2B 0d31537051c45bad52d922439d1cb9d69fc4a4bc2767d6a13bfe32a9edc978cadf9b1c508ae51532f5661291f32ed4b7c5e54f5fcd092eb4ebd7d3045521e9b8 SHA512 05511aafa978377152ea8ea1b70dd5558782bf634df5ae52453bfa65c7ec9270a12cd7a32e11872808a3289cfab2ef0380e129e84878511872e7cc95b0792453
+DIST marshmallow-2.20.5.tar.gz 152733 BLAKE2B ba509624e3715ace53eeb1a835f533172d676b3645ae3226c6da3727dafef7084bde896f3a66459112d599e3e422d600d150934313b813fea9d819658ce3b4bf SHA512 a02b6a3341d2cd08174937112eba2f69a07de59054a088eef64ac12703699e2b6f561ce76ebc0cb43334056f02f3898098bb0d3501ae8a1b6350f9a168eb3355
DIST marshmallow-3.0.1.tar.gz 168186 BLAKE2B 6c89fed45c144a855c692bee39390e1c80b2977274acb704095e76567e6ed00643704473f95abac7fabb4c1d1d96b90cb9a6fe3a127a09a0d2a4c72c02358baf SHA512 085a7e9b265bb86232222e4decb32fa172d62bca3ba3c5303f12715be1b0ab6553b1978e28db520a6a7a25778915c770ac83c607bdebf5e4d26746cd69f2d555
diff --git a/dev-python/marshmallow/marshmallow-2.20.5.ebuild b/dev-python/marshmallow/marshmallow-2.20.5.ebuild
new file mode 100644
index 000000000000..a9acebf6251e
--- /dev/null
+++ b/dev-python/marshmallow/marshmallow-2.20.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A lightweight library for converting complex datatypes to and from native Python datatypes."
+HOMEPAGE="https://github.com/marshmallow-code/marshmallow/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ )"
+
+src_prepare() {
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ if [[ ${EPYTHON} == python2.7 ]]; then
+ rm -rf tests/test_py3 || die
+ fi
+ py.test -v || die "tests failed under ${EPYTHON}"
+}