summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2018-07-14 20:23:00 -0400
committerAnthony G. Basile <blueness@gentoo.org>2018-07-14 20:23:30 -0400
commit6e465c01774203248fe78d4a6937d2dbb746f23c (patch)
tree741761f1826aa800f214665a5ba667edfe10fe3f /dev-python/marshmallow
parentdev-lang/vala: bump to 0.36.14 (diff)
downloadgentoo-6e465c01774203248fe78d4a6937d2dbb746f23c.tar.gz
gentoo-6e465c01774203248fe78d4a6937d2dbb746f23c.tar.bz2
gentoo-6e465c01774203248fe78d4a6937d2dbb746f23c.zip
dev-python/marshmallow: version bump to 3.0.0_beta12
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-python/marshmallow')
-rw-r--r--dev-python/marshmallow/Manifest1
-rw-r--r--dev-python/marshmallow/marshmallow-3.0.0_beta12.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/marshmallow/Manifest b/dev-python/marshmallow/Manifest
index f860974f7fa7..7c1d3abcb16a 100644
--- a/dev-python/marshmallow/Manifest
+++ b/dev-python/marshmallow/Manifest
@@ -1 +1,2 @@
+DIST marshmallow-3.0.0b12.tar.gz 153870 BLAKE2B 4279bb477861cbcef219a7442ffa29cb1f5bb084b08a9812256898771560add3d8e5dbcd2348d8734c1701131e02f33c69ca17f2d1d9010712e11ada96e0374f SHA512 3155503630b2a85eeb4b04769de79346b334975ab3611695806e799a76dfca78cc3c7d490b18158c757dd15d550fa408b651fa4c69b3e5eb147c4cf38613e2ab
DIST marshmallow-3.0.0b8.tar.gz 148882 BLAKE2B a83e9cb2ff7d5786e5a0d5c947e578f81d7d2ab008257df195096e06031b100cd6d31bdab3df63b6ab6704268b1915827dd89f7e5fce6a638d136686fc9ebc07 SHA512 34f7a974872d0cdad828e342788269ab19194e17f30716dc8db21bc3b86ab3f1be6bd5e31c7bcbeaad7b8c70acc39eab256eb938060eff42067f5f1b3ba51c1c
diff --git a/dev-python/marshmallow/marshmallow-3.0.0_beta12.ebuild b/dev-python/marshmallow/marshmallow-3.0.0_beta12.ebuild
new file mode 100644
index 000000000000..630eff899b7f
--- /dev/null
+++ b/dev-python/marshmallow/marshmallow-3.0.0_beta12.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+MY_P=${P/_beta/b}
+DESCRIPTION="A lightweight library for converting complex datatypes to and from native Python datatypes."
+HOMEPAGE="https://github.com/marshmallow-code/marshmallow/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ rm tests/test_py3/test_utils.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ py.test -v || die "tests failed under ${EPYTHON}"
+}