summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-14 16:46:11 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-14 18:04:15 +0100
commit8c27d9298f422c08ac17794706bc2ca78c0cee6c (patch)
tree9b10037279057902dcfb7a2b5a0e48e0ab761ede /dev-python/marshmallow
parentdev-python/pudb: Bump to 2022.1.1 (diff)
downloadgentoo-8c27d9298f422c08ac17794706bc2ca78c0cee6c.tar.gz
gentoo-8c27d9298f422c08ac17794706bc2ca78c0cee6c.tar.bz2
gentoo-8c27d9298f422c08ac17794706bc2ca78c0cee6c.zip
dev-python/marshmallow: Bump to 3.15.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/marshmallow')
-rw-r--r--dev-python/marshmallow/Manifest1
-rw-r--r--dev-python/marshmallow/marshmallow-3.15.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/marshmallow/Manifest b/dev-python/marshmallow/Manifest
index dd0fc022a959..abba62073be8 100644
--- a/dev-python/marshmallow/Manifest
+++ b/dev-python/marshmallow/Manifest
@@ -1 +1,2 @@
DIST marshmallow-3.14.0.tar.gz 175637 BLAKE2B 003bd5ee17d4c3db63fabcd75838f5455576eb8a741a0f1daba8c629ade145593538ba15d3ecd47d5b3cce65573f4ecd765c9badb0dd077c44b6d04537a1332f SHA512 3eed3cb7ba063c6a3503091b46443c6ad96f82e6c21e7ceb047b379dddad4429e59a8e5c828be258433b2743a8231bb338ef96f21767f17ed75fe44138bb0d64
+DIST marshmallow-3.15.0.tar.gz 179483 BLAKE2B 5cd660f4b1bf3ffb775e06659adce2f0da8bf46bd5376eb4407793925de60fce48ac633baced399314d9cef1faaf00f2643e56404cdc2c44e51b5b0c42ab533d SHA512 9d688466b9dfce7cd3307538aadb68c8297d3ee026a7a61953d361a9e52acafd00da81f48ab26771dba74bf8024117d53292763ab98cb78e2bbd7b5604bee4f1
diff --git a/dev-python/marshmallow/marshmallow-3.15.0.ebuild b/dev-python/marshmallow/marshmallow-3.15.0.ebuild
new file mode 100644
index 000000000000..f26c074cbd82
--- /dev/null
+++ b/dev-python/marshmallow/marshmallow-3.15.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A library for converting to and from native Python datatypes"
+HOMEPAGE="https://github.com/marshmallow-code/marshmallow/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest