summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-15 10:25:01 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-15 10:50:34 +0100
commitf14b48b11ac6a9af9ce16712f165aab754436282 (patch)
tree31ed5fc9c923fa687c7f846ca4b6d5216b55d0c7 /dev-python/matplotlib/matplotlib-1.5.1.ebuild
parentdev-python/html5lib: Don't test with dev-python/lxml-3.5.0 (diff)
downloadgentoo-f14b48b11ac6a9af9ce16712f165aab754436282.tar.gz
gentoo-f14b48b11ac6a9af9ce16712f165aab754436282.tar.bz2
gentoo-f14b48b11ac6a9af9ce16712f165aab754436282.zip
dev-python/matplotlib: Backport test fix and skip next one
Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/matplotlib/matplotlib-1.5.1.ebuild')
-rw-r--r--dev-python/matplotlib/matplotlib-1.5.1.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/dev-python/matplotlib/matplotlib-1.5.1.ebuild b/dev-python/matplotlib/matplotlib-1.5.1.ebuild
index 053e68ddca5c..9fabf36f5dca 100644
--- a/dev-python/matplotlib/matplotlib-1.5.1.ebuild
+++ b/dev-python/matplotlib/matplotlib-1.5.1.ebuild
@@ -110,6 +110,8 @@ RDEPEND="${COMMON_DEPEND}
# Other than that, the ebuild shall be fit for out-of-source build.
DISTUTILS_IN_SOURCE_BUILD=1
+PATCHES=( "${FILESDIR}"/${P}-test-fix-backport.patch )
+
pkg_setup() {
unset DISPLAY # bug #278524
use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( python2.7 )
@@ -154,10 +156,10 @@ python_prepare_all() {
-e "s:/usr/:${EPREFIX}/usr/:g" \
-i setupext.py || die
- # https://github.com/matplotlib/matplotlib/issues/5829
+ # https://github.com/matplotlib/matplotlib/issues/5857
sed \
- -e '/rasterize_10dpi/s:5e-2:10:g' \
- -i lib/matplotlib/tests/test_image.py || die
+ -e 's:test_pep8_conformance_examples:_&:g' \
+ -i lib/matplotlib/tests/test_coding_standards.py || die
export XDG_RUNTIME_DIR="${T}/runtime-dir"
mkdir "${XDG_RUNTIME_DIR}" || die