summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-21 15:18:30 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-21 20:04:48 +0100
commit92bde3479e70c62d57346a4f4ffc5eb8c6ed2603 (patch)
treebeb938fed136d91d0c017ea3b57fe48a467b3e10 /dev-python/matplotlib/matplotlib-3.8.2.ebuild
parentdev-python/fonttools: Update deselected tests for pypy3_10 fix (diff)
downloadgentoo-92bde3479e70c62d57346a4f4ffc5eb8c6ed2603.tar.gz
gentoo-92bde3479e70c62d57346a4f4ffc5eb8c6ed2603.tar.bz2
gentoo-92bde3479e70c62d57346a4f4ffc5eb8c6ed2603.zip
dev-python/matplotlib: Update deselected tests for pypy3_10 fix
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/matplotlib/matplotlib-3.8.2.ebuild')
-rw-r--r--dev-python/matplotlib/matplotlib-3.8.2.ebuild23
1 files changed, 14 insertions, 9 deletions
diff --git a/dev-python/matplotlib/matplotlib-3.8.2.ebuild b/dev-python/matplotlib/matplotlib-3.8.2.ebuild
index ce8672ca0961..dfd06adc7866 100644
--- a/dev-python/matplotlib/matplotlib-3.8.2.ebuild
+++ b/dev-python/matplotlib/matplotlib-3.8.2.ebuild
@@ -250,18 +250,9 @@ python_test() {
case ${EPYTHON} in
pypy3)
EPYTEST_DESELECT+=(
- # TypeError is raised when exception is raised in a starred
- # expression referencing a generator that uses "yield from"
- # and raises -- non-critical, since some exception is raised
- # after all
- # https://foss.heptapod.net/pypy/pypy/-/issues/4032
- tests/test_axes.py::test_bad_plot_args
- tests/test_axes.py::test_plot_errors
- tests/test_axes.py::test_plot_format_errors
# TODO: warning isn't passed through
tests/test_image.py::test_large_image
# TODO
- tests/test_legend.py::test_plot_multiple_label_incorrect_length_exception
tests/test_pickle.py::test_complete
tests/test_pickle.py::test_no_pyplot
tests/test_pickle.py::test_pickle_load_from_subprocess
@@ -272,6 +263,20 @@ python_test() {
tests/test_widgets.py::test_check_radio_buttons_image
tests/test_widgets.py::test_radio_buttons
)
+ if has_version "<dev-python/pypy3_10-exe-7.3.13_p2" ||
+ has_version "<dev-python/pypy3_10-exe-bin-7.3.13_p2"
+ then
+ EPYTEST_DESELECT+=(
+ # TypeError is raised when exception is raised in a starred
+ # expression referencing a generator that uses "yield from"
+ # and raises -- non-critical, since some exception is raised
+ # after all
+ # https://foss.heptapod.net/pypy/pypy/-/issues/4032
+ tests/test_axes.py::test_bad_plot_args
+ tests/test_axes.py::test_plot_errors
+ tests/test_axes.py::test_plot_format_errors
+ )
+ fi
;;
python3.11)
EPYTEST_DESELECT+=(