summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-03 11:35:56 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-03 12:20:01 +0200
commit35f5ab98f0fee6ed07a95ce8ed0477d4082ad539 (patch)
tree0ccfc9ffd85784ea14d4f903d0888e3c71122d98 /dev-python/matplotlib
parentdev-python/matplotlib: Run pytest directly (diff)
downloadgentoo-35f5ab98f0fee6ed07a95ce8ed0477d4082ad539.tar.gz
gentoo-35f5ab98f0fee6ed07a95ce8ed0477d4082ad539.tar.bz2
gentoo-35f5ab98f0fee6ed07a95ce8ed0477d4082ad539.zip
dev-python/matplotlib: Stop using in-source build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/matplotlib')
-rw-r--r--dev-python/matplotlib/matplotlib-3.5.2.ebuild7
1 files changed, 2 insertions, 5 deletions
diff --git a/dev-python/matplotlib/matplotlib-3.5.2.ebuild b/dev-python/matplotlib/matplotlib-3.5.2.ebuild
index 0aea928dc2d7..4184c7743b79 100644
--- a/dev-python/matplotlib/matplotlib-3.5.2.ebuild
+++ b/dev-python/matplotlib/matplotlib-3.5.2.ebuild
@@ -115,10 +115,6 @@ BDEPEND="
)
"
-# A few C++ source files are written to srcdir.
-# Other than that, the ebuild shall be fit for out-of-source build.
-DISTUTILS_IN_SOURCE_BUILD=1
-
distutils_enable_tests pytest
pkg_setup() {
@@ -256,6 +252,8 @@ python_compile_all() {
}
src_test() {
+ mkdir build || die
+ ln -s "${WORKDIR}/freetype-${FT_PV}" build/ || die
virtx distutils-r1_src_test
}
@@ -272,7 +270,6 @@ python_test() {
grep -v system_freetype "${BUILD_DIR}"/setup.cfg \
> "${BUILD_DIR}"/test-setup.cfg || die
local -x MPLSETUPCFG="${BUILD_DIR}"/test-setup.cfg
- ln -s "${WORKDIR}/freetype-${FT_PV}" "${BUILD_DIR}" || die
distutils-r1_python_compile -j1 --build-lib="${BUILD_DIR}"/test-lib
local -x PYTHONPATH=${BUILD_DIR}/test-lib:${PYTHONPATH}