summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-12 11:16:55 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-12 11:17:02 +0100
commit6a32620b949dd1c173d18ee081021c35bb2beb31 (patch)
treed43442ff2e7a575c33e823fe204cd79dabe63ea6 /dev-python/matplotlib
parentdev-lang/ruby: ppc stable wrt bug #565110 (diff)
downloadgentoo-6a32620b949dd1c173d18ee081021c35bb2beb31.tar.gz
gentoo-6a32620b949dd1c173d18ee081021c35bb2beb31.tar.bz2
gentoo-6a32620b949dd1c173d18ee081021c35bb2beb31.zip
dev-python/matplotlib: Drop old
obsoletes: Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=522840 Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/matplotlib')
-rw-r--r--dev-python/matplotlib/Manifest1
-rw-r--r--dev-python/matplotlib/matplotlib-1.4.2.ebuild247
2 files changed, 0 insertions, 248 deletions
diff --git a/dev-python/matplotlib/Manifest b/dev-python/matplotlib/Manifest
index ccfe5f433144..09f7f3048c8c 100644
--- a/dev-python/matplotlib/Manifest
+++ b/dev-python/matplotlib/Manifest
@@ -1,3 +1,2 @@
-DIST matplotlib-1.4.2.tar.gz 50139344 SHA256 17a3c7154f152d8dfed1f37517c0a8c5db6ade4f6334f684989c36dab84ddb54 SHA512 3525f4e6414042fabf8d18ce9041d61197465dc07c766730c187a512277907ba33f56d49d5a468d82f65bce57217e8eb48ecfa143e55152a15607b79a7b25adc WHIRLPOOL ce6e5a15676b939bda7ad1be0f27766314f60ed44ebfba1e73d2c3d00a31d5492722cde73f943de72da038772519068602e60c830af9ffdf52710a24ce98fe7a
DIST matplotlib-1.4.3.tar.gz 49933525 SHA256 5b9544472d9d6ab3d47423bdb5a0e64fdf913e505c1c083f25283dd0362bc0b6 SHA512 51b0f58b2618b47b653e17e4f6b6a1215d3a3b0f1331ce3555cc7435e365d9c75693f289ce12fe3bf8f69fd57b663e545f0f1c2c94e81eaa661cac0689e125f5 WHIRLPOOL 160ca48ecb44db58f1c56bd6e89592c5d1badd8e434fc25d32aa6d4d7a346ae7c7444d1c8e0c2ca2bf5c3246fd56cd93856ec7b1e3e51f5e471b9b55a0f2c1ad
DIST matplotlib-1.5.0.tar.gz 53962448 SHA256 67b08b1650a00a6317d94b76a30a47320087e5244920604c5462188cba0c2646 SHA512 559a3ef031ca65b431157f0dd50f7d81f2d854f92150ee2b9de5e44b31d49615bfdc049a682667bc2e1399b8cd724dfcefec8f4de7e92848fe5756f93ddef5fa WHIRLPOOL b30a7299dd0690cd0355883cbe7d335d76314bab85f5b67b326b0e600b479db3cd5e7f48e9e68d3604832e9605f5025c70ff0006b1980b945aeaf22f78e3469f
diff --git a/dev-python/matplotlib/matplotlib-1.4.2.ebuild b/dev-python/matplotlib/matplotlib-1.4.2.ebuild
deleted file mode 100644
index db8a59b5eece..000000000000
--- a/dev-python/matplotlib/matplotlib-1.4.2.ebuild
+++ /dev/null
@@ -1,247 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-
-PYTHON_REQ_USE='tk?,threads(+)'
-
-inherit distutils-r1 eutils flag-o-matic virtualx
-
-DESCRIPTION="Pure python plotting library with matlab like syntax"
-HOMEPAGE="http://matplotlib.org/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-SLOT="0"
-# Main license: matplotlib
-# Some modules: BSD
-# matplotlib/backends/qt4_editor: MIT
-# Fonts: BitstreamVera, OFL-1.1
-LICENSE="BitstreamVera BSD matplotlib MIT OFL-1.1"
-KEYWORDS="amd64 arm ppc ~ppc64 x86 ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="cairo doc excel examples fltk gtk gtk3 latex pyside qt4 test tk wxwidgets"
-
-# #456704 -- a lot of py2-only deps
-PY2_USEDEP=$(python_gen_usedep python2_7)
-COMMON_DEPEND="
- >=dev-python/numpy-1.6[${PYTHON_USEDEP}]
- dev-python/python-dateutil:0[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- >=dev-python/six-1.4[${PYTHON_USEDEP}]
- media-fonts/stix-fonts
- >=media-libs/freetype-2.3
- media-libs/libpng:0
- media-libs/qhull
- gtk? (
- dev-libs/glib:2=
- x11-libs/gdk-pixbuf
- x11-libs/gtk+:2=
- dev-python/pygtk[${PY2_USEDEP}] )
- wxwidgets? ( >=dev-python/wxpython-2.8:*[${PY2_USEDEP}] )"
-
-# internal copy of pycxx highly patched
-# dev-python/pycxx
-
-DEPEND="${COMMON_DEPEND}
- virtual/pkgconfig
- doc? (
- app-text/dvipng
- dev-python/pillow[${PYTHON_USEDEP}]
- dev-python/ipython[${PYTHON_USEDEP}]
- dev-python/numpydoc[${PYTHON_USEDEP}]
- dev-python/xlwt[${PY2_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-texlive/texlive-latexextra
- dev-texlive/texlive-fontsrecommended
- dev-texlive/texlive-latexrecommended
- media-gfx/graphviz[cairo]
- )
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- >=dev-python/nose-0.11.1[${PYTHON_USEDEP}]
- )"
-
-RDEPEND="${COMMON_DEPEND}
- >=dev-python/pyparsing-1.5.6[${PYTHON_USEDEP}]
- cairo? (
- || (
- dev-python/pycairo[${PYTHON_USEDEP}]
- dev-python/cairocffi[${PYTHON_USEDEP}]
- )
- )
- excel? ( dev-python/xlwt[${PY2_USEDEP}] )
- fltk? ( dev-python/pyfltk[${PY2_USEDEP}] )
- gtk3? (
- dev-python/pygobject:3[${PYTHON_USEDEP}]
- x11-libs/gtk+:3[introspection] )
- latex? (
- virtual/latex-base
- app-text/ghostscript-gpl
- app-text/dvipng
- app-text/poppler[utils]
- dev-texlive/texlive-fontsrecommended
- dev-texlive/texlive-latexextra
- dev-texlive/texlive-xetex
- )
- pyside? ( dev-python/pyside[X,${PYTHON_USEDEP}] )
- qt4? ( dev-python/PyQt4[X,${PYTHON_USEDEP}] )"
-
-PY2_FLAGS="|| ( $(python_gen_useflags python2_7) )"
-REQUIRED_USE="
- doc? ( ${PY2_FLAGS} )
- excel? ( ${PY2_FLAGS} )
- fltk? ( ${PY2_FLAGS} )
- gtk? ( ${PY2_FLAGS} )
- wxwidgets? ( ${PY2_FLAGS} )
- test? (
- cairo fltk latex pyside qt4 tk wxwidgets
- || ( gtk gtk3 )
- )"
-
-# A few C++ source files are written to srcdir.
-# Other than that, the ebuild shall be fit for out-of-source build.
-DISTUTILS_IN_SOURCE_BUILD=1
-
-pkg_setup() {
- unset DISPLAY # bug #278524
-}
-
-use_setup() {
- local uword="${2:-${1}}"
- if use ${1}; then
- echo "${uword} = True"
- echo "${uword}agg = True"
- else
- echo "${uword} = False"
- echo "${uword}agg = False"
- fi
-}
-
-python_prepare_all() {
-# Generates test failures, but fedora does it
-# local PATCHES=(
-# "${FILESDIR}"/${P}-unbundle-pycxx.patch
-# "${FILESDIR}"/${P}-unbundle-agg.patch
-# )
-# rm -r agg24 CXX || die
-# rm -r agg24 || die
-
- sed \
- -e 's/matplotlib.pyparsing_py[23]/pyparsing/g' \
- -i lib/matplotlib/{mathtext,fontconfig_pattern}.py \
- || die "sed pyparsing failed"
-
- # suggested by upstream
- sed \
- -e '/tol/s:32:35:g' \
- -i lib/matplotlib/tests/test_mathtext.py || die
-
- export XDG_RUNTIME_DIR="${T}/runtime-dir"
- mkdir "${XDG_RUNTIME_DIR}" || die
- chmod 0700 "${XDG_RUNTIME_DIR}" || die
-
- distutils-r1_python_prepare_all
-}
-
-python_configure_all() {
- append-flags -fno-strict-aliasing
- append-cppflags -DNDEBUG # or get old trying to do triangulation
-}
-
-python_configure() {
- mkdir -p "${BUILD_DIR}" || die
-
- # create setup.cfg (see setup.cfg.template for any changes).
-
- # common switches.
- cat > "${BUILD_DIR}"/setup.cfg <<- EOF
- [directories]
- basedirlist = "${EPREFIX}/usr"
- [provide_packages]
- pytz = False
- dateutil = False
- [gui_support]
- agg = True
- $(use_setup cairo)
- $(use_setup pyside)
- $(use_setup qt4)
- $(use_setup tk)
- EOF
-
- if use gtk3 && use cairo; then
- echo "gtk3cairo = True" >> "${BUILD_DIR}"/setup.cfg || die
- else
- echo "gtk3cairo = False" >> "${BUILD_DIR}"/setup.cfg || die
- fi
-
- if $(python_is_python3); then
- cat >> "${BUILD_DIR}"/setup.cfg <<- EOF
- six = True
- fltk = False
- fltkagg = False
- gtk = False
- gtkagg = False
- wx = False
- wxagg = False
- EOF
- else
- cat >> "${BUILD_DIR}"/setup.cfg <<-EOF
- six = False
- $(use_setup fltk)
- $(use_setup gtk)
- $(use_setup gtk3)
- $(use_setup wxwidgets wx)
- EOF
- fi
-}
-
-wrap_setup() {
- local MPLSETUPCFG=${BUILD_DIR}/setup.cfg
- export MPLSETUPCFG
- unset DISPLAY
-
- # Note: remove build... if switching to out-of-source build
- "${@}" build --build-lib="${BUILD_DIR}"/build/lib
-}
-
-python_compile() {
- wrap_setup distutils-r1_python_compile
-}
-
-python_compile_all() {
- if use doc; then
- cd doc || die
-
- # necessary for in-source build
- local -x PYTHONPATH="${BUILD_DIR}"/build/lib:${PYTHONPATH}
-
- VARTEXFONTS="${T}"/fonts \
- "${PYTHON}" ./make.py --small html || die
- fi
-}
-
-python_test() {
- wrap_setup distutils_install_for_testing
-
- cd "${TMPDIR}" || die
- VIRTUALX_COMMAND="${PYTHON}"
- virtualmake -c "import sys, matplotlib as m; sys.exit(0 if m.test(verbosity=2) else 1)" || \
- die "Tests fail with ${EPYTHON}"
-}
-
-python_install() {
- wrap_setup distutils-r1_python_install
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/build/html/. )
-
- distutils-r1_python_install_all
-
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}