summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-05-10 13:46:15 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-05-10 16:10:23 +0200
commit77d25c2e6c43eecf7805a3635188e3b9c57b81f3 (patch)
tree8be84f8dbff335bb90093f08771bec58cbd05c67 /dev-python/matplotlib
parentdev-python/matplotlib: Drop USE=pyside (diff)
downloadgentoo-77d25c2e6c43eecf7805a3635188e3b9c57b81f3.tar.gz
gentoo-77d25c2e6c43eecf7805a3635188e3b9c57b81f3.tar.bz2
gentoo-77d25c2e6c43eecf7805a3635188e3b9c57b81f3.zip
dev-python/matplotlib: Drop old
Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'dev-python/matplotlib')
-rw-r--r--dev-python/matplotlib/Manifest1
-rw-r--r--dev-python/matplotlib/files/matplotlib-1.4.3-backport-GH5291-2462.patch126
-rw-r--r--dev-python/matplotlib/files/matplotlib-1.4.3-cross-compile-1.patch50
-rw-r--r--dev-python/matplotlib/files/matplotlib-1.4.3-cross-compile-2.patch54
-rw-r--r--dev-python/matplotlib/files/matplotlib-1.4.3-cross-compile-3.patch58
-rw-r--r--dev-python/matplotlib/files/matplotlib-2.2.0-doc-make.patch10
-rw-r--r--dev-python/matplotlib/matplotlib-2.2.0.ebuild257
-rw-r--r--dev-python/matplotlib/matplotlib-2.2.2.ebuild257
8 files changed, 0 insertions, 813 deletions
diff --git a/dev-python/matplotlib/Manifest b/dev-python/matplotlib/Manifest
index 39b41fe50aa5..1eded76c0c56 100644
--- a/dev-python/matplotlib/Manifest
+++ b/dev-python/matplotlib/Manifest
@@ -1,3 +1,2 @@
DIST matplotlib-2.1.2.tar.bz2 33422388 BLAKE2B cb4826b563e9820a17e568de78044cb81af6fbe86221505fe9cfbab7e06fb95cc3a4eff8772443197cdddf6e49b4b59d204fab39054e627b95f0169b74f630a4 SHA512 861354363f625a45f40ce7b31263088c950c8664b8ef13f8019da222ba4a8df7d0a8ee048a1bd84102e472ec48318cfea9df905d58a28efb788ba59cd5348061
-DIST matplotlib-2.2.0.tar.gz 37246563 BLAKE2B 98d0b2cd6221f7e35d6d023b9c580733370b2def914e1ea879245a10399767f6269d81da561630518d1663da4b8afadf801c627b4c713cc37ad628a917cc446a SHA512 70932e4511e6748cc97c1c6b55705d31e93c1c2bd91b163158a4585dd916318337243ba89e6a62319c628fba955bb768bb73380991f6b7ed8678ef61413926e5
DIST matplotlib-2.2.2.tar.gz 37317332 BLAKE2B 4120265263c5b1e4ab57f7c0eb7a477b4071a5f219d1d6328d6ed51d44460217c7c4da82a4b7d13c6ba9f80308406a217f2dbcfa310f3137cbe8bc56a9ef0eef SHA512 1d21ef821190f22354098f8f0db6449f237acbf3c1419ab3815ecd4e9c6922fd3f00c4a8f60858e319b55b6fb2e8fe2922c0bf8e72b204e7edff0b409cf76320
diff --git a/dev-python/matplotlib/files/matplotlib-1.4.3-backport-GH5291-2462.patch b/dev-python/matplotlib/files/matplotlib-1.4.3-backport-GH5291-2462.patch
deleted file mode 100644
index d6b2ae860038..000000000000
--- a/dev-python/matplotlib/files/matplotlib-1.4.3-backport-GH5291-2462.patch
+++ /dev/null
@@ -1,126 +0,0 @@
-commit f98c4846dc3c15b3d24aafb973764cb9b860d935
-Author: Thomas A Caswell <tcaswell@gmail.com>
-Date: Sat Jan 10 16:10:29 2015 -0500
-
- MNT : removed deprecated method/kwargs from patheffects
-
- Deprecated in #2462 / 84e0063bd37c629f129d36c548e8ce3a30692cae
-
- attn @pelson had to known-fail a test which was using the
- proxy renderer to verify that PathEffectRender was working
- correctly.
-
-diff --git a/lib/matplotlib/patheffects.py b/lib/matplotlib/patheffects.py
-index 13f8ce0..19e1c4a 100644
---- a/lib/matplotlib/patheffects.py
-+++ b/lib/matplotlib/patheffects.py
-@@ -10,9 +10,7 @@ from __future__ import (absolute_import, division, print_function,
- import six
-
- from matplotlib.backend_bases import RendererBase
--from matplotlib.backends.backend_mixed import MixedModeRenderer
- import matplotlib.transforms as mtransforms
--import matplotlib.cbook as cbook
- from matplotlib.colors import colorConverter
- import matplotlib.patches as mpatches
-
-@@ -42,12 +40,6 @@ class AbstractPathEffect(object):
- return transform + self._offset_trans.clear().translate(offset_x,
- offset_y)
-
-- def get_proxy_renderer(self, renderer):
-- """Return a PathEffectRenderer instance for this PathEffect."""
-- cbook.deprecated('v1.4', name='get_proxy_renderer',
-- alternative='PathEffectRenderer')
-- return PathEffectRenderer([self], renderer)
--
- def _update_gc(self, gc, new_gc_dict):
- """
- Update the given GraphicsCollection with the given
-@@ -219,9 +211,9 @@ class withStroke(Stroke):
-
- class SimplePatchShadow(AbstractPathEffect):
- """A simple shadow via a filled patch."""
-- def __init__(self, offset=(2,-2),
-- shadow_rgbFace=None, alpha=None, patch_alpha=None,
-- rho=0.3, offset_xy=None, **kwargs):
-+ def __init__(self, offset=(2, -2),
-+ shadow_rgbFace=None, alpha=None,
-+ rho=0.3, **kwargs):
- """
- Parameters
- ----------
-@@ -241,24 +233,12 @@ class SimplePatchShadow(AbstractPathEffect):
- :meth:`AbstractPathEffect._update_gc`.
-
- """
-- if offset_xy is not None:
-- cbook.deprecated('v1.4', 'The offset_xy keyword is deprecated. '
-- 'Use the offset keyword instead.')
-- offset = offset_xy
- super(SimplePatchShadow, self).__init__(offset)
-
- if shadow_rgbFace is None:
- self._shadow_rgbFace = shadow_rgbFace
- else:
- self._shadow_rgbFace = colorConverter.to_rgba(shadow_rgbFace)
-- if patch_alpha is not None:
-- cbook.deprecated('v1.4', 'The patch_alpha keyword is deprecated. '
-- 'Use the alpha keyword instead. Transform your '
-- 'patch_alpha by alpha = 1 - patch_alpha')
-- if alpha is not None:
-- raise ValueError("Both alpha and patch_alpha were set. "
-- "Just use alpha.")
-- alpha = 1 - patch_alpha
-
- if alpha is None:
- alpha = 0.3
-diff --git a/lib/matplotlib/tests/test_patheffects.py b/lib/matplotlib/tests/test_patheffects.py
-index 8298ceb..5af71e5 100644
---- a/lib/matplotlib/tests/test_patheffects.py
-+++ b/lib/matplotlib/tests/test_patheffects.py
-@@ -5,7 +5,8 @@ import six
-
- import numpy as np
-
--from matplotlib.testing.decorators import image_comparison, cleanup
-+from matplotlib.testing.decorators import (image_comparison, cleanup,
-+ knownfailureif)
- import matplotlib.pyplot as plt
- import matplotlib.patheffects as path_effects
-
-@@ -84,19 +85,7 @@ def test_patheffect3():
-
-
- @cleanup
--def test_PathEffect_get_proxy():
-- pe = path_effects.AbstractPathEffect()
-- fig = plt.gcf()
-- renderer = fig.canvas.get_renderer()
--
-- with mock.patch('matplotlib.cbook.deprecated') as dep:
-- proxy_renderer = pe.get_proxy_renderer(renderer)
-- assert_equal(proxy_renderer._renderer, renderer)
-- assert_equal(proxy_renderer._path_effects, [pe])
-- dep.assert_called()
--
--
--@cleanup
-+@knownfailureif(True)
- def test_PathEffect_points_to_pixels():
- fig = plt.figure(dpi=150)
- p1, = plt.plot(range(10))
-@@ -116,11 +105,9 @@ def test_PathEffect_points_to_pixels():
- pe_renderer.points_to_pixels(15))
-
-
--def test_SimplePatchShadow_offset_xy():
-- with mock.patch('matplotlib.cbook.deprecated') as dep:
-- pe = path_effects.SimplePatchShadow(offset_xy=(4, 5))
-+def test_SimplePatchShadow_offset():
-+ pe = path_effects.SimplePatchShadow(offset=(4, 5))
- assert_equal(pe._offset, (4, 5))
-- dep.assert_called()
-
-
- @image_comparison(baseline_images=['collection'])
diff --git a/dev-python/matplotlib/files/matplotlib-1.4.3-cross-compile-1.patch b/dev-python/matplotlib/files/matplotlib-1.4.3-cross-compile-1.patch
deleted file mode 100644
index 065731441311..000000000000
--- a/dev-python/matplotlib/files/matplotlib-1.4.3-cross-compile-1.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-https://github.com/matplotlib/matplotlib/pull/4430
-
-From 08d26a80859023963bc2ffb41a0b6aed942685a9 Mon Sep 17 00:00:00 2001
-From: Mike Frysinger <vapier@chromium.org>
-Date: Fri, 15 May 2015 03:36:45 -0400
-Subject: [PATCH 1/3] setupext: respect $PKG_CONFIG
-
-When cross-compiling, it is common to set the PKG_CONFIG env var to a
-custom pkg-config that knows about the target. Make sure we respect
-that just like the standard pkg-config tools suggest (pkg.m4). If it
-isn't set, we use the same default as today -- "pkg-config".
----
- setupext.py | 7 ++++---
- 1 file changed, 4 insertions(+), 3 deletions(-)
-
-diff --git a/setupext.py b/setupext.py
-index 80b2a6c..29cddf9 100755
---- a/setupext.py
-+++ b/setupext.py
-@@ -253,7 +253,8 @@ class PkgConfig(object):
- self.has_pkgconfig = False
- else:
- self.set_pkgconfig_path()
-- status, output = getstatusoutput("pkg-config --help")
-+ self.pkgconfig = os.environ.get('PKG_CONFIG', 'pkg-config')
-+ status, output = getstatusoutput("%s --help" % self.pkgconfig)
- self.has_pkgconfig = (status == 0)
- if not self.has_pkgconfig:
- print("IMPORTANT WARNING:")
-@@ -286,7 +287,7 @@ class PkgConfig(object):
-
- executable = alt_exec
- if self.has_pkgconfig:
-- executable = 'pkg-config {0}'.format(package)
-+ executable = '%s %s' % (self.pkgconfig, package)
-
- use_defaults = True
-
-@@ -330,7 +331,7 @@ class PkgConfig(object):
- return None
-
- status, output = getstatusoutput(
-- "pkg-config %s --modversion" % (package))
-+ '%s %s --modversion' % (self.pkgconfig, package))
- if status == 0:
- return output
- return None
---
-2.4.0
-
diff --git a/dev-python/matplotlib/files/matplotlib-1.4.3-cross-compile-2.patch b/dev-python/matplotlib/files/matplotlib-1.4.3-cross-compile-2.patch
deleted file mode 100644
index 9580c70b2ae9..000000000000
--- a/dev-python/matplotlib/files/matplotlib-1.4.3-cross-compile-2.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-https://github.com/matplotlib/matplotlib/pull/4430
-
-From 3761303016cab0542891374032eca87e74d585bf Mon Sep 17 00:00:00 2001
-From: Mike Frysinger <vapier@chromium.org>
-Date: Fri, 15 May 2015 03:43:17 -0400
-Subject: [PATCH 2/3] setupext: do not mess with PKG_CONFIG_PATH
-
-The current code always sets PKG_CONFIG_PATH to build paths in / which
-breaks cross-compiling -- things like /usr/lib are for the build system
-(e.g. x86) and not for the target (e.g. arm). Since we're adding paths
-that are already the default for pkg-config, there's no point in trying
-to be smart here. Just punt the code.
-
-This basically reverts commit 101beb975d3a1218350f02bf68dc2a43ac8ff148.
----
- setupext.py | 15 ---------------
- 1 file changed, 15 deletions(-)
-
-diff --git a/setupext.py b/setupext.py
-index 29cddf9..57d80e7 100755
---- a/setupext.py
-+++ b/setupext.py
-@@ -252,7 +252,6 @@ class PkgConfig(object):
- if sys.platform == 'win32':
- self.has_pkgconfig = False
- else:
-- self.set_pkgconfig_path()
- self.pkgconfig = os.environ.get('PKG_CONFIG', 'pkg-config')
- status, output = getstatusoutput("%s --help" % self.pkgconfig)
- self.has_pkgconfig = (status == 0)
-@@ -262,20 +261,6 @@ class PkgConfig(object):
- " pkg-config is not installed.\n"
- " matplotlib may not be able to find some of its dependencies")
-
-- def set_pkgconfig_path(self):
-- pkgconfig_path = sysconfig.get_config_var('LIBDIR')
-- if pkgconfig_path is None:
-- return
--
-- pkgconfig_path = os.path.join(pkgconfig_path, 'pkgconfig')
-- if not os.path.isdir(pkgconfig_path):
-- return
--
-- try:
-- os.environ['PKG_CONFIG_PATH'] += ':' + pkgconfig_path
-- except KeyError:
-- os.environ['PKG_CONFIG_PATH'] = pkgconfig_path
--
- def setup_extension(self, ext, package, default_include_dirs=[],
- default_library_dirs=[], default_libraries=[],
- alt_exec=None):
---
-2.4.0
-
diff --git a/dev-python/matplotlib/files/matplotlib-1.4.3-cross-compile-3.patch b/dev-python/matplotlib/files/matplotlib-1.4.3-cross-compile-3.patch
deleted file mode 100644
index 21fdf128863c..000000000000
--- a/dev-python/matplotlib/files/matplotlib-1.4.3-cross-compile-3.patch
+++ /dev/null
@@ -1,58 +0,0 @@
-https://github.com/matplotlib/matplotlib/pull/4430
-
-From d077e49be318c851f6bbd64708efeed78a3ece3f Mon Sep 17 00:00:00 2001
-From: Mike Frysinger <vapier@chromium.org>
-Date: Fri, 15 May 2015 03:49:02 -0400
-Subject: [PATCH 3/3] setupext: do not hardcode system -I/-L paths
-
-The native compiler should already know the right paths to look for
-includes and libraries. Hardcoding a specific list of those paths
-breaks both cross-compiling and multilib. In the former, paths like
-/usr/include and /usr/lib are for x86 but when you want to build for
-arm, mixing them leads to bad failures. In the latter, paths like
-/usr/lib typically hold 32it libraries, but when you're building for
-64bit, you want the libs from /usr/lib64. This goes even further as
-there are other mixed ABIs like /usr/libx32 and /usr/lib32, neither
-of which are handled here.
-
-Instead, delete the code entirely and rely on the compiler being
-properly configured. If you want to use a misconfigured compiler,
-you can always set CFLAGS/CPPFLAGS/LDFLAGS to include the -I/-L
-that your system needs.
----
- setupext.py | 12 +-----------
- 1 file changed, 1 insertion(+), 11 deletions(-)
-
-diff --git a/setupext.py b/setupext.py
-index 57d80e7..7473e3a 100755
---- a/setupext.py
-+++ b/setupext.py
-@@ -216,9 +216,7 @@ sysconfig.customize_compiler = my_customize_compiler
-
- def make_extension(name, files, *args, **kwargs):
- """
-- Make a new extension. Automatically sets include_dirs and
-- library_dirs to the base directories appropriate for this
-- platform.
-+ Make a new extension.
-
- `name` is the name of the extension.
-
-@@ -228,14 +226,6 @@ def make_extension(name, files, *args, **kwargs):
- `distutils.core.Extension` constructor.
- """
- ext = DelayedExtension(name, files, *args, **kwargs)
-- for dir in get_base_dirs():
-- include_dir = os.path.join(dir, 'include')
-- if os.path.exists(include_dir):
-- ext.include_dirs.append(include_dir)
-- for lib in ('lib', 'lib64'):
-- lib_dir = os.path.join(dir, lib)
-- if os.path.exists(lib_dir):
-- ext.library_dirs.append(lib_dir)
- ext.include_dirs.append('.')
-
- return ext
---
-2.4.0
-
diff --git a/dev-python/matplotlib/files/matplotlib-2.2.0-doc-make.patch b/dev-python/matplotlib/files/matplotlib-2.2.0-doc-make.patch
deleted file mode 100644
index 7ca0c6974234..000000000000
--- a/dev-python/matplotlib/files/matplotlib-2.2.0-doc-make.patch
+++ /dev/null
@@ -1,10 +0,0 @@
-diff -r -U2 matplotlib-2.1.2.orig/doc/conf.py matplotlib-2.1.2/doc/conf.py
---- matplotlib-2.1.2.orig/doc/conf.py 2018-01-19 11:07:49.000000000 +0700
-+++ matplotlib-2.1.2/doc/conf.py 2018-01-21 20:06:44.120901546 +0700
-@@ -136,5 +136,5 @@
- }
-
--plot_gallery = 'True'
-+plot_gallery = True
-
- # Add any paths that contain templates here, relative to this directory.
diff --git a/dev-python/matplotlib/matplotlib-2.2.0.ebuild b/dev-python/matplotlib/matplotlib-2.2.0.ebuild
deleted file mode 100644
index d1fc0c28597f..000000000000
--- a/dev-python/matplotlib/matplotlib-2.2.0.ebuild
+++ /dev/null
@@ -1,257 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-PYTHON_REQ_USE='tk?,threads(+)'
-
-inherit distutils-r1 flag-o-matic virtualx toolchain-funcs prefix
-
-DESCRIPTION="Pure python plotting library with matlab like syntax"
-HOMEPAGE="https://matplotlib.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-# Main license: matplotlib
-# Some modules: BSD
-# matplotlib/backends/qt4_editor: MIT
-# Fonts: BitstreamVera, OFL-1.1
-LICENSE="BitstreamVera BSD matplotlib MIT OFL-1.1"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
-IUSE="cairo doc excel examples gtk2 gtk3 latex pyside qt5 test tk wxwidgets"
-
-PY2_FLAGS="|| ( $(python_gen_useflags python2_7) )"
-REQUIRED_USE="
- doc? ( ${PY2_FLAGS} )
- excel? ( ${PY2_FLAGS} )
- gtk2? ( ${PY2_FLAGS} )
- wxwidgets? ( ${PY2_FLAGS} )
- test? (
- cairo latex qt5 tk wxwidgets
- || ( gtk2 gtk3 )
- )"
-
-# #456704 -- a lot of py2-only deps
-PY2_USEDEP=$(python_gen_usedep python2_7)
-PY2_DEPEND="
- $(python_gen_cond_dep 'dev-python/functools32[${PYTHON_USEDEP}]' python2_7)
- $(python_gen_cond_dep 'dev-python/subprocess32[${PYTHON_USEDEP}]' python2_7)
- $(python_gen_cond_dep 'dev-python/backports-functools-lru-cache[${PYTHON_USEDEP}]' python2_7)"
-COMMON_DEPEND="
- dev-python/cycler[${PYTHON_USEDEP}]
- >=dev-python/numpy-1.7.1[${PYTHON_USEDEP}]
- dev-python/python-dateutil:0[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- >=dev-python/six-1.10[${PYTHON_USEDEP}]
- media-fonts/stix-fonts
- media-libs/freetype:2
- media-libs/libpng:0
- >=media-libs/qhull-2013
- >=dev-python/kiwisolver-1.0.0[${PYTHON_USEDEP}]
- cairo? ( dev-python/cairocffi[${PYTHON_USEDEP}] )
- gtk2? (
- dev-libs/glib:2=
- x11-libs/gdk-pixbuf
- x11-libs/gtk+:2
- dev-python/pygtk[${PY2_USEDEP}] )
- wxwidgets? ( >=dev-python/wxpython-2.8:*[${PY2_USEDEP}] )"
-
-# internal copy of pycxx highly patched
-# dev-python/pycxx
-
-DEPEND="${COMMON_DEPEND}
- ${PY2_DEPEND}
- dev-python/versioneer[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- virtual/pkgconfig
- doc? (
- app-text/dvipng
- dev-python/colorspacious[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
- dev-python/ipython[${PYTHON_USEDEP}]
- dev-python/mock[${PY2_USEDEP}]
- dev-python/numpydoc[${PYTHON_USEDEP}]
- sci-libs/scipy[${PYTHON_USEDEP}]
- >=dev-python/sphinx-1.3.0[${PYTHON_USEDEP}]
- >=dev-python/sphinx-gallery-0.1.12[${PYTHON_USEDEP}]
- dev-python/xlwt[${PYTHON_USEDEP}]
- dev-texlive/texlive-latexextra
- dev-texlive/texlive-fontsrecommended
- dev-texlive/texlive-latexrecommended
- media-gfx/graphviz[cairo]
- )
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- >=dev-python/nose-0.11.1[${PYTHON_USEDEP}]
- )"
-
-RDEPEND="${COMMON_DEPEND}
- ${PY2_DEPEND}
- >=dev-python/pyparsing-1.5.6[${PYTHON_USEDEP}]
- excel? ( dev-python/xlwt[${PYTHON_USEDEP}] )
- gtk3? (
- dev-python/pygobject:3[${PYTHON_USEDEP}]
- x11-libs/gtk+:3[introspection] )
- latex? (
- virtual/latex-base
- app-text/ghostscript-gpl
- app-text/dvipng
- app-text/poppler[utils]
- dev-texlive/texlive-fontsrecommended
- dev-texlive/texlive-latexextra
- dev-texlive/texlive-xetex
- )
- pyside? ( dev-python/pyside[X,${PYTHON_USEDEP}] )
- qt5? ( dev-python/PyQt5[gui,widgets,${PYTHON_USEDEP}] )
- "
-
-# A few C++ source files are written to srcdir.
-# Other than that, the ebuild shall be fit for out-of-source build.
-DISTUTILS_IN_SOURCE_BUILD=1
-
-pkg_setup() {
- unset DISPLAY # bug #278524
-}
-
-use_setup() {
- local uword="${2:-${1}}"
- if use ${1}; then
- echo "${uword} = True"
- echo "${uword}agg = True"
- else
- echo "${uword} = False"
- echo "${uword}agg = False"
- fi
-}
-
-python_prepare_all() {
-# Generates test failures, but fedora does it
-# local PATCHES=(
-# "${FILESDIR}"/${P}-unbundle-pycxx.patch
-# "${FILESDIR}"/${P}-unbundle-agg.patch
-# )
-# rm -r agg24 CXX || die
-# rm -r agg24 || die
-
-# cat > lib/${PN}/externals/six.py <<-EOF
-# from __future__ import absolute_import
-# from six import *
-# EOF
-
- local PATCHES=( "${FILESDIR}"/${P}-doc-make.patch )
-
- sed \
- -e 's/matplotlib.pyparsing_py[23]/pyparsing/g' \
- -i lib/matplotlib/{mathtext,fontconfig_pattern}.py \
- || die "sed pyparsing failed"
-
- hprefixify setupext.py
-
- export XDG_RUNTIME_DIR="${T}/runtime-dir"
- mkdir "${XDG_RUNTIME_DIR}" || die
- chmod 0700 "${XDG_RUNTIME_DIR}" || die
-
- distutils-r1_python_prepare_all
-}
-
-python_configure_all() {
- append-flags -fno-strict-aliasing
- append-cppflags -DNDEBUG # or get old trying to do triangulation
- tc-export PKG_CONFIG
-}
-
-python_configure() {
- mkdir -p "${BUILD_DIR}" || die
-
- # create setup.cfg (see setup.cfg.template for any changes).
-
- # common switches.
- cat > "${BUILD_DIR}"/setup.cfg <<- EOF || die
- [directories]
- basedirlist = ${EPREFIX}/usr
- [provide_packages]
- pytz = False
- dateutil = False
- [packages]
- tests = $(usex test True False)
- [gui_support]
- agg = True
- qt4 = False
- qt4agg = False
- $(use_setup cairo)
- $(use_setup gtk3)
- $(use_setup pyside)
- $(use_setup qt5)
- $(use_setup tk)
- EOF
-
- if use gtk3 && use cairo; then
- echo "gtk3cairo = True" >> "${BUILD_DIR}"/setup.cfg || die
- else
- echo "gtk3cairo = False" >> "${BUILD_DIR}"/setup.cfg || die
- fi
-
- if python_is_python3; then
- cat >> "${BUILD_DIR}"/setup.cfg <<- EOF || die
- gtk = False
- gtkagg = False
- wx = False
- wxagg = False
- EOF
- else
- cat >> "${BUILD_DIR}"/setup.cfg <<-EOF || die
- $(use_setup gtk2 gtk)
- $(use_setup wxwidgets wx)
- EOF
- fi
-}
-
-wrap_setup() {
- local -x MPLSETUPCFG=${BUILD_DIR}/setup.cfg
- unset DISPLAY
- "$@"
-}
-
-python_compile() {
- wrap_setup distutils-r1_python_compile --build-lib="${BUILD_DIR}"/lib
-}
-
-python_compile_all() {
- if use doc; then
- cd doc || die
-
- # necessary for in-source build
- local -x PYTHONPATH="${BUILD_DIR}"/build/lib:${PYTHONPATH}
-
- VARTEXFONTS="${T}"/fonts \
- emake SPHINXOPTS= O=-Dplot_formats=png:100 html
- fi
-}
-
-python_test() {
- wrap_setup distutils_install_for_testing
-
- virtx "${EPYTHON}" -c "import sys, matplotlib as m; sys.exit(0 if m.test(verbosity=2) else 1)"
-}
-
-python_install() {
- wrap_setup distutils-r1_python_install
-
- # mpl_toolkits namespace
- python_moduleinto mpl_toolkits
- python_domodule lib/mpl_toolkits/__init__.py
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/build/html/. )
-
- distutils-r1_python_install_all
-
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-
- find "${D}" -name '*.pth' -delete || die
-}
diff --git a/dev-python/matplotlib/matplotlib-2.2.2.ebuild b/dev-python/matplotlib/matplotlib-2.2.2.ebuild
deleted file mode 100644
index d1fc0c28597f..000000000000
--- a/dev-python/matplotlib/matplotlib-2.2.2.ebuild
+++ /dev/null
@@ -1,257 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-PYTHON_REQ_USE='tk?,threads(+)'
-
-inherit distutils-r1 flag-o-matic virtualx toolchain-funcs prefix
-
-DESCRIPTION="Pure python plotting library with matlab like syntax"
-HOMEPAGE="https://matplotlib.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-# Main license: matplotlib
-# Some modules: BSD
-# matplotlib/backends/qt4_editor: MIT
-# Fonts: BitstreamVera, OFL-1.1
-LICENSE="BitstreamVera BSD matplotlib MIT OFL-1.1"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
-IUSE="cairo doc excel examples gtk2 gtk3 latex pyside qt5 test tk wxwidgets"
-
-PY2_FLAGS="|| ( $(python_gen_useflags python2_7) )"
-REQUIRED_USE="
- doc? ( ${PY2_FLAGS} )
- excel? ( ${PY2_FLAGS} )
- gtk2? ( ${PY2_FLAGS} )
- wxwidgets? ( ${PY2_FLAGS} )
- test? (
- cairo latex qt5 tk wxwidgets
- || ( gtk2 gtk3 )
- )"
-
-# #456704 -- a lot of py2-only deps
-PY2_USEDEP=$(python_gen_usedep python2_7)
-PY2_DEPEND="
- $(python_gen_cond_dep 'dev-python/functools32[${PYTHON_USEDEP}]' python2_7)
- $(python_gen_cond_dep 'dev-python/subprocess32[${PYTHON_USEDEP}]' python2_7)
- $(python_gen_cond_dep 'dev-python/backports-functools-lru-cache[${PYTHON_USEDEP}]' python2_7)"
-COMMON_DEPEND="
- dev-python/cycler[${PYTHON_USEDEP}]
- >=dev-python/numpy-1.7.1[${PYTHON_USEDEP}]
- dev-python/python-dateutil:0[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- >=dev-python/six-1.10[${PYTHON_USEDEP}]
- media-fonts/stix-fonts
- media-libs/freetype:2
- media-libs/libpng:0
- >=media-libs/qhull-2013
- >=dev-python/kiwisolver-1.0.0[${PYTHON_USEDEP}]
- cairo? ( dev-python/cairocffi[${PYTHON_USEDEP}] )
- gtk2? (
- dev-libs/glib:2=
- x11-libs/gdk-pixbuf
- x11-libs/gtk+:2
- dev-python/pygtk[${PY2_USEDEP}] )
- wxwidgets? ( >=dev-python/wxpython-2.8:*[${PY2_USEDEP}] )"
-
-# internal copy of pycxx highly patched
-# dev-python/pycxx
-
-DEPEND="${COMMON_DEPEND}
- ${PY2_DEPEND}
- dev-python/versioneer[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- virtual/pkgconfig
- doc? (
- app-text/dvipng
- dev-python/colorspacious[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
- dev-python/ipython[${PYTHON_USEDEP}]
- dev-python/mock[${PY2_USEDEP}]
- dev-python/numpydoc[${PYTHON_USEDEP}]
- sci-libs/scipy[${PYTHON_USEDEP}]
- >=dev-python/sphinx-1.3.0[${PYTHON_USEDEP}]
- >=dev-python/sphinx-gallery-0.1.12[${PYTHON_USEDEP}]
- dev-python/xlwt[${PYTHON_USEDEP}]
- dev-texlive/texlive-latexextra
- dev-texlive/texlive-fontsrecommended
- dev-texlive/texlive-latexrecommended
- media-gfx/graphviz[cairo]
- )
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- >=dev-python/nose-0.11.1[${PYTHON_USEDEP}]
- )"
-
-RDEPEND="${COMMON_DEPEND}
- ${PY2_DEPEND}
- >=dev-python/pyparsing-1.5.6[${PYTHON_USEDEP}]
- excel? ( dev-python/xlwt[${PYTHON_USEDEP}] )
- gtk3? (
- dev-python/pygobject:3[${PYTHON_USEDEP}]
- x11-libs/gtk+:3[introspection] )
- latex? (
- virtual/latex-base
- app-text/ghostscript-gpl
- app-text/dvipng
- app-text/poppler[utils]
- dev-texlive/texlive-fontsrecommended
- dev-texlive/texlive-latexextra
- dev-texlive/texlive-xetex
- )
- pyside? ( dev-python/pyside[X,${PYTHON_USEDEP}] )
- qt5? ( dev-python/PyQt5[gui,widgets,${PYTHON_USEDEP}] )
- "
-
-# A few C++ source files are written to srcdir.
-# Other than that, the ebuild shall be fit for out-of-source build.
-DISTUTILS_IN_SOURCE_BUILD=1
-
-pkg_setup() {
- unset DISPLAY # bug #278524
-}
-
-use_setup() {
- local uword="${2:-${1}}"
- if use ${1}; then
- echo "${uword} = True"
- echo "${uword}agg = True"
- else
- echo "${uword} = False"
- echo "${uword}agg = False"
- fi
-}
-
-python_prepare_all() {
-# Generates test failures, but fedora does it
-# local PATCHES=(
-# "${FILESDIR}"/${P}-unbundle-pycxx.patch
-# "${FILESDIR}"/${P}-unbundle-agg.patch
-# )
-# rm -r agg24 CXX || die
-# rm -r agg24 || die
-
-# cat > lib/${PN}/externals/six.py <<-EOF
-# from __future__ import absolute_import
-# from six import *
-# EOF
-
- local PATCHES=( "${FILESDIR}"/${P}-doc-make.patch )
-
- sed \
- -e 's/matplotlib.pyparsing_py[23]/pyparsing/g' \
- -i lib/matplotlib/{mathtext,fontconfig_pattern}.py \
- || die "sed pyparsing failed"
-
- hprefixify setupext.py
-
- export XDG_RUNTIME_DIR="${T}/runtime-dir"
- mkdir "${XDG_RUNTIME_DIR}" || die
- chmod 0700 "${XDG_RUNTIME_DIR}" || die
-
- distutils-r1_python_prepare_all
-}
-
-python_configure_all() {
- append-flags -fno-strict-aliasing
- append-cppflags -DNDEBUG # or get old trying to do triangulation
- tc-export PKG_CONFIG
-}
-
-python_configure() {
- mkdir -p "${BUILD_DIR}" || die
-
- # create setup.cfg (see setup.cfg.template for any changes).
-
- # common switches.
- cat > "${BUILD_DIR}"/setup.cfg <<- EOF || die
- [directories]
- basedirlist = ${EPREFIX}/usr
- [provide_packages]
- pytz = False
- dateutil = False
- [packages]
- tests = $(usex test True False)
- [gui_support]
- agg = True
- qt4 = False
- qt4agg = False
- $(use_setup cairo)
- $(use_setup gtk3)
- $(use_setup pyside)
- $(use_setup qt5)
- $(use_setup tk)
- EOF
-
- if use gtk3 && use cairo; then
- echo "gtk3cairo = True" >> "${BUILD_DIR}"/setup.cfg || die
- else
- echo "gtk3cairo = False" >> "${BUILD_DIR}"/setup.cfg || die
- fi
-
- if python_is_python3; then
- cat >> "${BUILD_DIR}"/setup.cfg <<- EOF || die
- gtk = False
- gtkagg = False
- wx = False
- wxagg = False
- EOF
- else
- cat >> "${BUILD_DIR}"/setup.cfg <<-EOF || die
- $(use_setup gtk2 gtk)
- $(use_setup wxwidgets wx)
- EOF
- fi
-}
-
-wrap_setup() {
- local -x MPLSETUPCFG=${BUILD_DIR}/setup.cfg
- unset DISPLAY
- "$@"
-}
-
-python_compile() {
- wrap_setup distutils-r1_python_compile --build-lib="${BUILD_DIR}"/lib
-}
-
-python_compile_all() {
- if use doc; then
- cd doc || die
-
- # necessary for in-source build
- local -x PYTHONPATH="${BUILD_DIR}"/build/lib:${PYTHONPATH}
-
- VARTEXFONTS="${T}"/fonts \
- emake SPHINXOPTS= O=-Dplot_formats=png:100 html
- fi
-}
-
-python_test() {
- wrap_setup distutils_install_for_testing
-
- virtx "${EPYTHON}" -c "import sys, matplotlib as m; sys.exit(0 if m.test(verbosity=2) else 1)"
-}
-
-python_install() {
- wrap_setup distutils-r1_python_install
-
- # mpl_toolkits namespace
- python_moduleinto mpl_toolkits
- python_domodule lib/mpl_toolkits/__init__.py
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/build/html/. )
-
- distutils-r1_python_install_all
-
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-
- find "${D}" -name '*.pth' -delete || die
-}