summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-02 10:57:20 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-02 12:47:12 +0100
commitc7f78999ea9d5db7ef747956487231d0a76792d9 (patch)
tree01bdb28bdc256a76a77855ca90df158d959c51d7 /dev-python/matplotlib
parentdev-python/pyclimate: Drop KEYWORDS to testing (diff)
downloadgentoo-c7f78999ea9d5db7ef747956487231d0a76792d9.tar.gz
gentoo-c7f78999ea9d5db7ef747956487231d0a76792d9.tar.bz2
gentoo-c7f78999ea9d5db7ef747956487231d0a76792d9.zip
dev-python/matplotlib: Unset DISPLAY during build to fix sandbox problems
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=564296 Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/matplotlib')
-rw-r--r--dev-python/matplotlib/matplotlib-1.4.2.ebuild1
-rw-r--r--dev-python/matplotlib/matplotlib-1.4.3.ebuild1
-rw-r--r--dev-python/matplotlib/matplotlib-1.5.0.ebuild1
-rw-r--r--dev-python/matplotlib/matplotlib-9999.ebuild1
4 files changed, 4 insertions, 0 deletions
diff --git a/dev-python/matplotlib/matplotlib-1.4.2.ebuild b/dev-python/matplotlib/matplotlib-1.4.2.ebuild
index defc79b79f4b..f5b16b1f5680 100644
--- a/dev-python/matplotlib/matplotlib-1.4.2.ebuild
+++ b/dev-python/matplotlib/matplotlib-1.4.2.ebuild
@@ -202,6 +202,7 @@ python_configure() {
wrap_setup() {
local MPLSETUPCFG=${BUILD_DIR}/setup.cfg
export MPLSETUPCFG
+ unset DISPLAY
# Note: remove build... if switching to out-of-source build
"${@}" build --build-lib="${BUILD_DIR}"/build/lib
diff --git a/dev-python/matplotlib/matplotlib-1.4.3.ebuild b/dev-python/matplotlib/matplotlib-1.4.3.ebuild
index a31fa3f6d9a7..86adcbf5e7e2 100644
--- a/dev-python/matplotlib/matplotlib-1.4.3.ebuild
+++ b/dev-python/matplotlib/matplotlib-1.4.3.ebuild
@@ -219,6 +219,7 @@ python_configure() {
wrap_setup() {
local MPLSETUPCFG=${BUILD_DIR}/setup.cfg
export MPLSETUPCFG
+ unset DISPLAY
# Note: remove build... if switching to out-of-source build
"${@}" build --build-lib="${BUILD_DIR}"/build/lib
diff --git a/dev-python/matplotlib/matplotlib-1.5.0.ebuild b/dev-python/matplotlib/matplotlib-1.5.0.ebuild
index f644ffe5def9..cc6fe7edd615 100644
--- a/dev-python/matplotlib/matplotlib-1.5.0.ebuild
+++ b/dev-python/matplotlib/matplotlib-1.5.0.ebuild
@@ -224,6 +224,7 @@ python_configure() {
wrap_setup() {
local MPLSETUPCFG=${BUILD_DIR}/setup.cfg
export MPLSETUPCFG
+ unset DISPLAY
# Note: remove build... if switching to out-of-source build
"${@}" build --build-lib="${BUILD_DIR}"/build/lib
diff --git a/dev-python/matplotlib/matplotlib-9999.ebuild b/dev-python/matplotlib/matplotlib-9999.ebuild
index 64665e727b18..a62eac5ee1f0 100644
--- a/dev-python/matplotlib/matplotlib-9999.ebuild
+++ b/dev-python/matplotlib/matplotlib-9999.ebuild
@@ -215,6 +215,7 @@ python_configure() {
wrap_setup() {
local MPLSETUPCFG=${BUILD_DIR}/setup.cfg
export MPLSETUPCFG
+ unset DISPLAY
# Note: remove build... if switching to out-of-source build
"${@}" build --build-lib="${BUILD_DIR}"/build/lib