summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2020-01-01 21:23:18 +0100
committerSebastian Pipping <sping@gentoo.org>2020-01-01 21:24:35 +0100
commitd0931eee092094ae0883b5fbfc295e0b72e36c98 (patch)
treebc8e247e6bee0ded3dc2684bc58497e6d9e6437b /dev-python/mechanize/mechanize-0.4.5.ebuild
parentnet-misc/python-x2go: 0.6.1.3 bump (diff)
downloadgentoo-d0931eee092094ae0883b5fbfc295e0b72e36c98.tar.gz
gentoo-d0931eee092094ae0883b5fbfc295e0b72e36c98.tar.bz2
gentoo-d0931eee092094ae0883b5fbfc295e0b72e36c98.zip
dev-python/mechanize: 0.4.5 + py3 + missing dependency
Closes: https://bugs.gentoo.org/685230 Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-2.3.84, Repoman-2.3.20
Diffstat (limited to 'dev-python/mechanize/mechanize-0.4.5.ebuild')
-rw-r--r--dev-python/mechanize/mechanize-0.4.5.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/mechanize/mechanize-0.4.5.ebuild b/dev-python/mechanize/mechanize-0.4.5.ebuild
new file mode 100644
index 000000000000..3d8cffc186c8
--- /dev/null
+++ b/dev-python/mechanize/mechanize-0.4.5.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{6,7,8}} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Stateful programmatic web browsing in Python"
+HOMEPAGE="https://github.com/python-mechanize/mechanize"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( BSD ZPL )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="doc"
+
+DEPEND=">=dev-python/html5lib-0.999999999[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+python_test() {
+ "${PYTHON}" run_tests.py || die
+}