summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-02-10 11:47:22 +0100
committerLouis Sautier <sbraz@gentoo.org>2020-02-10 13:59:23 +0100
commita1f2fad69ac800b92bf83575e159f7e0796bf66b (patch)
tree882c9232754ce945839843bdd38ae728aa66033d /dev-python/meld3/meld3-2.0.0.ebuild
parentx11-libs/libGLw: Fix for -fno-common (diff)
downloadgentoo-a1f2fad69ac800b92bf83575e159f7e0796bf66b.tar.gz
gentoo-a1f2fad69ac800b92bf83575e159f7e0796bf66b.tar.bz2
gentoo-a1f2fad69ac800b92bf83575e159f7e0796bf66b.zip
dev-python/meld3: bump to 2.0.0, drop Py2.7, add Py3.8
Package-Manager: Portage-2.3.87, Repoman-2.3.20 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/meld3/meld3-2.0.0.ebuild')
-rw-r--r--dev-python/meld3/meld3-2.0.0.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/dev-python/meld3/meld3-2.0.0.ebuild b/dev-python/meld3/meld3-2.0.0.ebuild
new file mode 100644
index 000000000000..ea462a1e77e9
--- /dev/null
+++ b/dev-python/meld3/meld3-2.0.0.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( pypy3 python3_{6,7,8} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="meld3 is an HTML/XML templating engine"
+HOMEPAGE="https://github.com/supervisor/meld3 https://pypi.org/project/meld3/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="repoze"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests unittest