summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-12-17 14:30:01 +0100
committerJustin Lecher <jlec@gentoo.org>2015-12-17 15:48:46 +0100
commit724eb58dd79d741bd2f19890466b1545dc4ce31d (patch)
treeede6901e2bd584a3b793e02309ad230c841e8f13 /dev-python/memory_profiler/memory_profiler-0.40.ebuild
parentmedia-video/vlc: correct dep string to cater to paludis (diff)
downloadgentoo-724eb58dd79d741bd2f19890466b1545dc4ce31d.tar.gz
gentoo-724eb58dd79d741bd2f19890466b1545dc4ce31d.tar.bz2
gentoo-724eb58dd79d741bd2f19890466b1545dc4ce31d.zip
dev-python/memory_profiler: Version Bump
Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/memory_profiler/memory_profiler-0.40.ebuild')
-rw-r--r--dev-python/memory_profiler/memory_profiler-0.40.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/memory_profiler/memory_profiler-0.40.ebuild b/dev-python/memory_profiler/memory_profiler-0.40.ebuild
new file mode 100644
index 000000000000..9595e036119b
--- /dev/null
+++ b/dev-python/memory_profiler/memory_profiler-0.40.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A module for monitoring memory usage of a python program"
+HOMEPAGE="http://pypi.python.org/pypi/memory_profiler https://github.com/fabianp/memory_profiler"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/psutil[${PYTHON_USEDEP}]
+"
+DEPEND="${REDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ ${EPYTHON} -m memory_profiler test/test_func.py || die
+ ${EPYTHON} -m memory_profiler test/test_loop.py || die
+ ${EPYTHON} -m memory_profiler test/test_as.py || die
+ ${EPYTHON} -m memory_profiler test/test_global.py || die
+ ${EPYTHON} -m memory_profiler test/test_precision_command_line.py || die
+ ${EPYTHON} test/test_import.py || die
+ ${EPYTHON} test/test_memory_usage.py || die
+ ${EPYTHON} test/test_precision_import.py || die
+}