summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-01-16 14:33:46 +0100
committerBenda Xu <heroxbd@gentoo.org>2020-02-09 20:43:47 +0800
commita9ed6e5fe6c474c5166f5a238bd720ed49bae90a (patch)
tree145cd6e88855ab3b578ce2e18a6b510cd5c5382d /dev-python/memory_profiler/memory_profiler-0.57.ebuild
parentwww-client/dillo: Update live ebuild (diff)
downloadgentoo-a9ed6e5fe6c474c5166f5a238bd720ed49bae90a.tar.gz
gentoo-a9ed6e5fe6c474c5166f5a238bd720ed49bae90a.tar.bz2
gentoo-a9ed6e5fe6c474c5166f5a238bd720ed49bae90a.zip
dev-python/memory_profiler: Fix ebuild
Add examples flag Add py3_8 Put setuptools in rdepend Bug: https://github.com/gentoo/gentoo/pull/14344 Bug: https://bugs.gentoo.org/705872 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Benda Xu <heroxbd@gentoo.org>
Diffstat (limited to 'dev-python/memory_profiler/memory_profiler-0.57.ebuild')
-rw-r--r--dev-python/memory_profiler/memory_profiler-0.57.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/memory_profiler/memory_profiler-0.57.ebuild b/dev-python/memory_profiler/memory_profiler-0.57.ebuild
new file mode 100644
index 000000000000..9b0b4220a754
--- /dev/null
+++ b/dev-python/memory_profiler/memory_profiler-0.57.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="A module for monitoring memory usage of a python program"
+HOMEPAGE="https://pypi.org/project/memory_profiler/ https://github.com/fabianp/memory_profiler"
+SRC_URI="https://github.com/pythonprofilers/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+IUSE="examples"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+# dev-lang/mercury: collision on 'mprof'
+# https://bugs.gentoo.org/571176
+RDEPEND="dev-python/psutil[${PYTHON_USEDEP}]
+ !dev-lang/mercury"
+
+distutils_enable_tests pytest
+
+python_test() {
+ ${EPYTHON} -m memory_profiler test/test_as.py || die
+ ${EPYTHON} -m memory_profiler test/test_func.py || die
+ ${EPYTHON} -m memory_profiler test/test_gen.py || die
+ ${EPYTHON} -m memory_profiler test/test_loop.py || die
+ ${EPYTHON} -m memory_profiler test/test_loop_decorated.py || die
+ ${EPYTHON} -m memory_profiler test/test_mprofile.py || die
+ ${EPYTHON} -m memory_profiler test/test_nested.py || die
+ ${EPYTHON} -m memory_profiler test/test_precision_command_line.py || die
+ ${EPYTHON} -m memory_profiler test/test_unicode.py || die
+
+ ${EPYTHON} test/test_exception.py || die
+ ${EPYTHON} test/test_exit_code.py || die
+ ${EPYTHON} test/test_global.py || die
+ ${EPYTHON} test/test_import.py || die
+ ${EPYTHON} test/test_memory_usage.py || die
+ ${EPYTHON} test/test_mprof.py || die
+ ${EPYTHON} test/test_precision_import.py || die
+ ${EPYTHON} test/test_stream_unicode.py || die
+ ${EPYTHON} test/test_tracemalloc.py || die
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+
+ distutils-r1_python_install_all
+}