summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-20 07:18:18 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-20 07:38:28 +0200
commit45aa5c5d911423ae1738a45939938347cdeb5f65 (patch)
treea161c09dc4506ea244424fe943f9abefe5c50d10 /dev-python/micawber
parentdev-python/readme-renderer: Bump to 40.0 (diff)
downloadgentoo-45aa5c5d911423ae1738a45939938347cdeb5f65.tar.gz
gentoo-45aa5c5d911423ae1738a45939938347cdeb5f65.tar.bz2
gentoo-45aa5c5d911423ae1738a45939938347cdeb5f65.zip
dev-python/micawber: Bump to 0.5.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/micawber')
-rw-r--r--dev-python/micawber/Manifest1
-rw-r--r--dev-python/micawber/micawber-0.5.5.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/micawber/Manifest b/dev-python/micawber/Manifest
index d3107d2795f0..495cb8c8e850 100644
--- a/dev-python/micawber/Manifest
+++ b/dev-python/micawber/Manifest
@@ -1 +1,2 @@
DIST micawber-0.5.4.gh.tar.gz 34963 BLAKE2B 1c311e2d1c8f32f81be466893bf1eb34f8c38901b168a97c88f2043aba1624fa8b6d12460c7470c3bbd720ae29af23ab808a9464b13ebf5ec193f5818b6f3aa1 SHA512 26879174071256fd3f95e92b0ea01b11a44eab767aa7bb43ff62221212ea0ab1ad33b67060e2dec33963abad599b864573f6a9d5a98fcd8f1a6633a3c73d7c80
+DIST micawber-0.5.5.gh.tar.gz 35109 BLAKE2B 3d60f8b27246a82001437481c5feec638a9673cf9b5427f1c69ca3f84e17935eba4e88078ab7d2818eaa1d9d98b22946a1ab5c3ff0f6261bd44a2150c663a616 SHA512 93949a813d99e5b46e8e06b4e9f501fa74092bc64ebab71572734334cd9889c2d4546a086775005b7f99d18df56222623ae7761cb6ba2f42c7f78c10a86e2d26
diff --git a/dev-python/micawber/micawber-0.5.5.ebuild b/dev-python/micawber/micawber-0.5.5.ebuild
new file mode 100644
index 000000000000..8ceecbb56d37
--- /dev/null
+++ b/dev-python/micawber/micawber-0.5.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A small library for extracting rich content from urls"
+HOMEPAGE="
+ https://github.com/coleifer/micawber/
+ https://pypi.org/project/micawber/
+"
+SRC_URI="
+ https://github.com/coleifer/micawber/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/django[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ "${EPYTHON}" runtests.py || die "Tests failed with ${EPYTHON}"
+}