summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-09-29 01:41:05 +0100
committerMarek Szuba <marecki@gentoo.org>2022-09-29 01:41:05 +0100
commit645cb4f8e13fab06313ed93fe834a1072a5fe1f6 (patch)
tree6526a89cad991aa85ffb346359af5273fdcd786c /dev-python/mido
parentdev-python/mido: new package, add 1.2.10 (diff)
downloadgentoo-645cb4f8e13fab06313ed93fe834a1072a5fe1f6.tar.gz
gentoo-645cb4f8e13fab06313ed93fe834a1072a5fe1f6.tar.bz2
gentoo-645cb4f8e13fab06313ed93fe834a1072a5fe1f6.zip
dev-python/mido: remove stray patch
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-python/mido')
-rw-r--r--dev-python/mido/files/python-rtmidi-1.4.9-unbundle_rtmidi.patch60
1 files changed, 0 insertions, 60 deletions
diff --git a/dev-python/mido/files/python-rtmidi-1.4.9-unbundle_rtmidi.patch b/dev-python/mido/files/python-rtmidi-1.4.9-unbundle_rtmidi.patch
deleted file mode 100644
index ecd9f53b108c..000000000000
--- a/dev-python/mido/files/python-rtmidi-1.4.9-unbundle_rtmidi.patch
+++ /dev/null
@@ -1,60 +0,0 @@
---- a/setup.py
-+++ b/setup.py
-@@ -102,7 +102,7 @@
-
- # Set up options for compiling the _rtmidi Extension
- if cythonize:
-- sources = [join(SRC_DIR, "_rtmidi.pyx"), join(SRC_DIR, "rtmidi", "RtMidi.cpp")]
-+ sources = [join(SRC_DIR, "_rtmidi.pyx")]
- elif exists(join(SRC_DIR, "_rtmidi.cpp")):
- cythonize = lambda x: x # noqa
- sources = [join(SRC_DIR, "_rtmidi.cpp"), join(SRC_DIR, "rtmidi", "RtMidi.cpp")]
-@@ -145,18 +145,18 @@
-
-
- if sys.platform.startswith('linux'):
-- if alsa and find_library('asound'):
-- define_macros.append(("__LINUX_ALSA__", None))
-- libraries.append('asound')
--
-- if jack:
-- check_for_jack(define_macros, libraries)
--
- if not find_library('pthread'):
- sys.exit("The 'pthread' library is required to build python-rtmidi on"
- "Linux. Please install the libc6 development package.")
-+ if not find_library('rtmidi'):
-+ sys.exit("Failed to find librtmidi")
-
- libraries.append("pthread")
-+
-+ res = subprocess.check_output(['pkg-config', '--variable', 'includedir', 'rtmidi'])
-+ rtmidi_include_dir = res.decode().strip()
-+ include_dirs.append(rtmidi_include_dir)
-+ libraries.append('rtmidi')
- elif sys.platform.startswith('darwin'):
- if jack:
- check_for_jack(define_macros, libraries)
-@@ -197,7 +197,7 @@
- # Finally, set up our distribution
- setup(
- packages=['rtmidi'],
-- ext_modules=cythonize(extensions),
-+ ext_modules=cythonize(extensions, include_path=[ rtmidi_include_dir ]),
- tests_require=[], # Test dependencies are handled by tox
- # On systems without a RTC (e.g. Raspberry Pi), system time will be the
- # Unix epoch when booted without network connection, which makes zip fail,
---- a/tests/test_rtmidi.py
-+++ b/tests/test_rtmidi.py
-@@ -54,11 +54,6 @@
- else:
- self.assertEqual(res, rtmidi.API_UNSPECIFIED)
-
-- def test_get_rtmidi_version(self):
-- version = rtmidi.get_rtmidi_version()
-- self.assertTrue(isinstance(version, string_types))
-- self.assertEqual(version, '4.0.0')
--
-
- class BaseTests:
- NOTE_ON = [0x90, 48, 100]