summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-16 04:12:35 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-16 05:01:53 +0100
commit653e4f1a3f178f7f66edaadd9b9eeeb72dc47836 (patch)
treebf7e0a3baed08442df1ca6ae067dc9ead24064dc /dev-python/mido
parentdev-python/dask: Bump to 2023.12.1 (diff)
downloadgentoo-653e4f1a3f178f7f66edaadd9b9eeeb72dc47836.tar.gz
gentoo-653e4f1a3f178f7f66edaadd9b9eeeb72dc47836.tar.bz2
gentoo-653e4f1a3f178f7f66edaadd9b9eeeb72dc47836.zip
dev-python/mido: Bump to 1.3.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/mido')
-rw-r--r--dev-python/mido/Manifest1
-rw-r--r--dev-python/mido/mido-1.3.2.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/mido/Manifest b/dev-python/mido/Manifest
index b1b39338d4c6..f2ed50fa4159 100644
--- a/dev-python/mido/Manifest
+++ b/dev-python/mido/Manifest
@@ -1,2 +1,3 @@
DIST mido-1.3.0.tar.gz 121330 BLAKE2B bf6a20e12b609dc89600fa3b93ccf857fe9aad47ea71564773280c5cf0069b59deec3f8f7263d9949ccf0848b2b73e3e904057c3645069097a85469c8d78a391 SHA512 7e91daa704e72204af30af9c16a2e712a60794f8180c49d78de870381d50aac31029c01ae23fbb7c00947e299c1feba89622ea2648d54bd8786f497cf0a1bd20
DIST mido-1.3.1.tar.gz 124019 BLAKE2B 0d132d3f993b0f6d663b0347c7286e5d0d6bf32fe164bc1ccdd980ebce0edb83e00e37ab1f62759111b6e3b5b32edd6b822abbec208c93abe14d884de3cf490a SHA512 a40cc8a140cbf1db815cad9b03c7f91e32292cf25aaea2b45613cbb4f1ee573847de3c8ad8bc24a8ef3cf68c01ce166881fe7156dd445b150c6f2a14e655d968
+DIST mido-1.3.2.tar.gz 124216 BLAKE2B f6eb230ad8ec02a9a2f0e5e1b332a70334433a1decddb341b1c315b878bdc2e7aefed3527c408a3da9264e7344439a69bf28bd2b4d810c29e4f4278aee8303b9 SHA512 5f31057a972f8ecdadcd135f2ffd68f70388bb8777f6bc7fa14c84aa8c57988a4f7443283dd093930352989d8a097177c6543a38440184c705cfaf82e3aaff83
diff --git a/dev-python/mido/mido-1.3.2.ebuild b/dev-python/mido/mido-1.3.2.ebuild
new file mode 100644
index 000000000000..fc7fb16de40f
--- /dev/null
+++ b/dev-python/mido/mido-1.3.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="MIDI Objects, a library for working with MIDI messages and ports"
+HOMEPAGE="
+ https://pypi.org/project/mido/
+ https://github.com/mido/mido
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+portmidi rtmidi"
+
+RDEPEND="
+ >=dev-python/packaging-23.1[${PYTHON_USEDEP}]
+ portmidi? ( media-libs/portmidi )
+ rtmidi? ( dev-python/python-rtmidi[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # performance test
+ tests/midifiles/test_tracks.py::test_merge_large_midifile
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}