summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-04-23 19:40:02 +0200
committerMichał Górny <mgorny@gentoo.org>2020-04-23 19:50:37 +0200
commite53e8e74fd013ac939284545c79cdc048bce56d8 (patch)
tree42cc4520979e7f4905466fbb60d3f96038b674fd /dev-python/mimerender/mimerender-0.6.0.ebuild
parentsci-visualization/pythonprop: Add support for Python3.7 (diff)
downloadgentoo-e53e8e74fd013ac939284545c79cdc048bce56d8.tar.gz
gentoo-e53e8e74fd013ac939284545c79cdc048bce56d8.tar.bz2
gentoo-e53e8e74fd013ac939284545c79cdc048bce56d8.zip
dev-python/mimerender: Fix tests, py3.{7,8}
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/mimerender/mimerender-0.6.0.ebuild')
-rw-r--r--dev-python/mimerender/mimerender-0.6.0.ebuild20
1 files changed, 14 insertions, 6 deletions
diff --git a/dev-python/mimerender/mimerender-0.6.0.ebuild b/dev-python/mimerender/mimerender-0.6.0.ebuild
index 05935778d43a..9c2a32f940a6 100644
--- a/dev-python/mimerender/mimerender-0.6.0.ebuild
+++ b/dev-python/mimerender/mimerender-0.6.0.ebuild
@@ -1,19 +1,27 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
-PYTHON_COMPAT=( python3_6 )
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
inherit distutils-r1
DESCRIPTION="RESTful HTTP Content Negotiation for Flask, Bottle, web.py and webapp2"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-HOMEPAGE="https://pypi.org/project/mimerender/"
+HOMEPAGE="
+ https://pypi.org/project/mimerender/
+ https://github.com/martinblech/mimerender/"
+SRC_URI="
+ https://github.com/martinblech/mimerender/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
RDEPEND="dev-python/mimeparse[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest
+
+python_test() {
+ "${EPYTHON}" src/test.py -v || die "Tests fail with ${EPYTHON}"
+}