summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-21 09:48:31 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-21 10:59:22 +0200
commit6d0c48857a0b15e124bb818e1daa3701211e6029 (patch)
tree69ec2bd11fa66a2b822b1d060bf836ffa22cf553 /dev-python/mistletoe/mistletoe-1.2.0.ebuild
parentnet-im/skypeforlinux: add 8.102.0.211 (diff)
downloadgentoo-6d0c48857a0b15e124bb818e1daa3701211e6029.tar.gz
gentoo-6d0c48857a0b15e124bb818e1daa3701211e6029.tar.bz2
gentoo-6d0c48857a0b15e124bb818e1daa3701211e6029.zip
dev-python/mistletoe: Bump to 1.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/mistletoe/mistletoe-1.2.0.ebuild')
-rw-r--r--dev-python/mistletoe/mistletoe-1.2.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/mistletoe/mistletoe-1.2.0.ebuild b/dev-python/mistletoe/mistletoe-1.2.0.ebuild
new file mode 100644
index 000000000000..7aef7cc9a0be
--- /dev/null
+++ b/dev-python/mistletoe/mistletoe-1.2.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A fast, extensible Markdown parser in pure Python"
+HOMEPAGE="
+ https://github.com/miyuchina/mistletoe/
+ https://pypi.org/project/mistletoe/
+"
+# pypi has incomplete test suite
+SRC_URI="
+ https://github.com/miyuchina/mistletoe/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# NB: pygments is technically optional but we like syntax highlighting
+RDEPEND="
+ dev-python/pygments[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest