summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-15 09:42:43 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-15 10:17:42 +0200
commit7a03e47fc9495069caa9279e6da089acdc6161a9 (patch)
treec35cf338b4acd784d9c328441c0a0a715ea47c1b /dev-python/mistune/mistune-2.0.4.ebuild
parentapp-admin/awscli: Bump to 1.25.30 (diff)
downloadgentoo-7a03e47fc9495069caa9279e6da089acdc6161a9.tar.gz
gentoo-7a03e47fc9495069caa9279e6da089acdc6161a9.tar.bz2
gentoo-7a03e47fc9495069caa9279e6da089acdc6161a9.zip
dev-python/mistune: Bump to 2.0.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/mistune/mistune-2.0.4.ebuild')
-rw-r--r--dev-python/mistune/mistune-2.0.4.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/mistune/mistune-2.0.4.ebuild b/dev-python/mistune/mistune-2.0.4.ebuild
new file mode 100644
index 000000000000..718413dc53f7
--- /dev/null
+++ b/dev-python/mistune/mistune-2.0.4.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="The fastest markdown parser in pure Python"
+HOMEPAGE="
+ https://github.com/lepture/mistune/
+ https://pypi.org/project/mistune/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+distutils_enable_tests pytest