summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-03-28 15:13:52 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-04-09 15:37:42 +0300
commitbf2b367c92d4972464494a61b730aa26d627a2cc (patch)
tree1049cd02257d5beec2242ba06a298ebf833c707c /dev-python/mkdocs-bootswatch/mkdocs-bootswatch-1.1.ebuild
parentdev-python/mkdocs-bootstrap: version bump 1.1 (diff)
downloadgentoo-bf2b367c92d4972464494a61b730aa26d627a2cc.tar.gz
gentoo-bf2b367c92d4972464494a61b730aa26d627a2cc.tar.bz2
gentoo-bf2b367c92d4972464494a61b730aa26d627a2cc.zip
dev-python/mkdocs-bootswatch: version bump 1.1
Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Closes: https://github.com/gentoo/gentoo/pull/15150 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/mkdocs-bootswatch/mkdocs-bootswatch-1.1.ebuild')
-rw-r--r--dev-python/mkdocs-bootswatch/mkdocs-bootswatch-1.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/mkdocs-bootswatch/mkdocs-bootswatch-1.1.ebuild b/dev-python/mkdocs-bootswatch/mkdocs-bootswatch-1.1.ebuild
new file mode 100644
index 000000000000..54f7d5a812c3
--- /dev/null
+++ b/dev-python/mkdocs-bootswatch/mkdocs-bootswatch-1.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Bootswatch themes for MkDocs"
+HOMEPAGE="https://www.mkdocs.org https://github.com/mkdocs/mkdocs-bootswatch"
+SRC_URI="https://github.com/mkdocs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="doc"
+
+DEPEND="dev-python/mkdocs"
+
+python_compile_all() {
+ default
+ if use doc; then
+ mkdocs build || die "Failed to make docs"
+ # Colliding files found by ecompress:
+ rm site/sitemap.xml.gz || die
+ HTML_DOCS=( "site/." )
+ fi
+}