summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-14 17:06:50 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-14 17:39:34 +0200
commit1542808b506b4338fe338925c7ae68e868da02ce (patch)
tree268b1983ac348264e465f26c1130ebfe2d362020 /dev-python/mkdocstrings-python/mkdocstrings-python-1.7.0.ebuild
parentdev-python/brotlicffi: Bump to 1.1.0.0 (diff)
downloadgentoo-1542808b506b4338fe338925c7ae68e868da02ce.tar.gz
gentoo-1542808b506b4338fe338925c7ae68e868da02ce.tar.bz2
gentoo-1542808b506b4338fe338925c7ae68e868da02ce.zip
dev-python/mkdocstrings-python: Bump to 1.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/mkdocstrings-python/mkdocstrings-python-1.7.0.ebuild')
-rw-r--r--dev-python/mkdocstrings-python/mkdocstrings-python-1.7.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/mkdocstrings-python/mkdocstrings-python-1.7.0.ebuild b/dev-python/mkdocstrings-python/mkdocstrings-python-1.7.0.ebuild
new file mode 100644
index 000000000000..f0b94cc2c39d
--- /dev/null
+++ b/dev-python/mkdocstrings-python/mkdocstrings-python-1.7.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=pdm-backend
+
+inherit distutils-r1
+
+DESCRIPTION="Python handler for dev-python/mkdocstrings"
+HOMEPAGE="
+ https://mkdocstrings.github.io/python/
+ https://github.com/mkdocstrings/python/
+ https://pypi.org/project/mkdocstrings-python/
+"
+# Tests need files absent from the PyPI tarballs
+SRC_URI="
+ https://github.com/mkdocstrings/python/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/python-${PV}"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ >=dev-python/griffe-0.35[${PYTHON_USEDEP}]
+ dev-python/mkdocstrings[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mkdocs-material[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export PDM_BUILD_SCM_VERSION=${PV}