summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-10-26 00:49:58 +0100
committerMarek Szuba <marecki@gentoo.org>2023-10-26 01:14:03 +0100
commit639c82bfe6c7e004a3c1251bad6e3bd71e9a96b1 (patch)
tree9093b0767dbee3840df6a0a969d1c4a4f0323976 /dev-python/mkdocstrings/mkdocstrings-0.23.0.ebuild
parentdev-python/mkdocs-autorefs: enable py3.12 (diff)
downloadgentoo-639c82bfe6c7e004a3c1251bad6e3bd71e9a96b1.tar.gz
gentoo-639c82bfe6c7e004a3c1251bad6e3bd71e9a96b1.tar.bz2
gentoo-639c82bfe6c7e004a3c1251bad6e3bd71e9a96b1.zip
dev-python/mkdocstrings: update test dependencies
One, test_inventory.py is skipped in its entirety unless Sphinx is present. Two, markdown-exec is now in the tree. Unfortunately it turns out there are additional test dependencies we haven't packaged yet, therefore keep tests/test_inventory.py::test_sphinx_load_mkdocstrings_inventory_file deselected for now and merely update the relevant comment. Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-python/mkdocstrings/mkdocstrings-0.23.0.ebuild')
-rw-r--r--dev-python/mkdocstrings/mkdocstrings-0.23.0.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-python/mkdocstrings/mkdocstrings-0.23.0.ebuild b/dev-python/mkdocstrings/mkdocstrings-0.23.0.ebuild
index 1f12e1c46f72..0e8648a7cba5 100644
--- a/dev-python/mkdocstrings/mkdocstrings-0.23.0.ebuild
+++ b/dev-python/mkdocstrings/mkdocstrings-0.23.0.ebuild
@@ -3,6 +3,7 @@
EAPI=8
+# py3.12 blocked by mkdocs-material
DISTUTILS_USE_PEP517=pdm-backend
PYTHON_COMPAT=( python3_{10..11} )
@@ -34,8 +35,10 @@ RDEPEND="
"
BDEPEND="
test? (
+ dev-python/markdown-exec[${PYTHON_USEDEP}]
dev-python/mkdocs-material[${PYTHON_USEDEP}]
dev-python/mkdocstrings-python[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
)
"
@@ -46,7 +49,7 @@ EPYTEST_DESELECT=(
tests/test_plugin.py::test_disabling_plugin
# WTF, it tries to unlink installed files from installed package?!
tests/test_handlers.py::test_extended_templates
- # TODO: package markdown-exec
+ # Needs unpackaged mkdocs-callouts, mkdocs-literate-nav, and possibly more
tests/test_inventory.py::test_sphinx_load_mkdocstrings_inventory_file
# Internet
tests/test_inventory.py::test_load_inventory