summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-20 17:38:27 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-20 17:52:08 +0200
commit309212c90bd7c259cda0b548eec213d6b006e8b1 (patch)
treed48cfd928e774e677246d1f157737759c989850a /dev-python/mongomock/mongomock-3.21.0.ebuild
parentdev-python/hypothesis: Bump to 5.37.4 (diff)
downloadgentoo-309212c90bd7c259cda0b548eec213d6b006e8b1.tar.gz
gentoo-309212c90bd7c259cda0b548eec213d6b006e8b1.tar.bz2
gentoo-309212c90bd7c259cda0b548eec213d6b006e8b1.zip
dev-python/mongomock: Bump to 3.21.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/mongomock/mongomock-3.21.0.ebuild')
-rw-r--r--dev-python/mongomock/mongomock-3.21.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/mongomock/mongomock-3.21.0.ebuild b/dev-python/mongomock/mongomock-3.21.0.ebuild
new file mode 100644
index 000000000000..fe73bdcae26a
--- /dev/null
+++ b/dev-python/mongomock/mongomock-3.21.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library to help testing Python code that interacts with MongoDB via Pymongo"
+HOMEPAGE="https://github.com/mongomock/mongomock https://pypi.org/project/mongomock/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND=">=dev-python/pbr-5.1.1[${PYTHON_USEDEP}]"
+
+RDEPEND="
+ >=dev-python/pymongo-3.10.1[${PYTHON_USEDEP}]
+ >=dev-python/sentinels-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.14.0[${PYTHON_USEDEP}]"
+
+src_test() {
+ # Use NO_LOCAL_MONGO to disable tests that need a MongoDB instance.
+ # TZ=UTC needed for date/time tests to pass
+ TZ=UTC NO_LOCAL_MONGO=1 distutils-r1_src_test
+}
+
+distutils_enable_tests pytest