summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-13 07:52:55 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-13 09:18:42 +0200
commit1066f2f4c025ed0413b50974284dbe4bed001601 (patch)
tree13cab480bd59c9d54d89f4890e80c564730ccf35 /dev-python/moto
parentdev-libs/libtomcrypt: sparc stable wrt bug #851381 (diff)
downloadgentoo-1066f2f4c025ed0413b50974284dbe4bed001601.tar.gz
gentoo-1066f2f4c025ed0413b50974284dbe4bed001601.tar.bz2
gentoo-1066f2f4c025ed0413b50974284dbe4bed001601.zip
dev-python/moto: Bump to 3.1.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/moto')
-rw-r--r--dev-python/moto/Manifest1
-rw-r--r--dev-python/moto/moto-3.1.13.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/dev-python/moto/Manifest b/dev-python/moto/Manifest
index 6ceda5714ee5..ec3bc288b459 100644
--- a/dev-python/moto/Manifest
+++ b/dev-python/moto/Manifest
@@ -1,4 +1,5 @@
DIST moto-3.1.10.tar.gz 2314423 BLAKE2B ad09f8cb70a1541dce640c870355c349f9a932beec1c98d3d4739bda89e773670fb0209b9ec7aca3a250472d425048d444b08edf2f1555c6777251de14c5a80a SHA512 138e5be59fffcfe4579b6cb292f4f8ec21c5d05723bcd66cae85bcc0f60991ac84310206d5a0fe8361135ff04573173f41b276021981d6f7844a726f18b54f83
DIST moto-3.1.11.tar.gz 2320905 BLAKE2B 14cd572defd974e428a77f75be32f576d7cb222fa80a37b5f72bdb8f10fd36be3b456d7d660fe7943862824393b48b4d70687dde191ffc49a49db7ee05772994 SHA512 2e1a84beef161442f74dee95b1e5dc7b23c77d9b001c27b0d8ee3c429c5da13be9a6d0074bc26bacad72f5ea82b0eb85e88dd2adb585f7dfd688bd1e3d9cc5e9
DIST moto-3.1.12.tar.gz 2323555 BLAKE2B f2ecefc5dbbc3f4ce66a799ec255cad40ce466f62fe3bfb0885866c7d0125884a0fef299b58fdcf1cb5da7ef58ac513d844b2fbae6d6545dcb38f2a3bbb2cda4 SHA512 29b8d0d71f3227784eddd05959434451ad88c9c0346b3684360e57bd3df8b9734f781d263bf992ac946749c88b433f6c86c1fc71d71a2dc565633c812579c297
+DIST moto-3.1.13.tar.gz 2330638 BLAKE2B ded004bcd783f623edd5b198c39b0245bc847233be46e101b8556adf71c8a7495a175957b3c5c475ca66c392df0999f53c8cedbb439cbb39cd5566e610887cc2 SHA512 95708e6638ab9a8d68b1acaf3af14fc381584e2d978d7f03ee500c50cd2b3409d99633f0e211bfb86c40335e67581f9e6ff3dc7934f8e91fc9f8be8311de8b5b
DIST moto-3.1.9.tar.gz 2308059 BLAKE2B 85f5c084fc81d74e8297ab0a78e3823bb6e98b1d4fdb70b802dabfa3ba11475670c3bfda27f48069e5298691a8ca71c98acf156c3b15ab79ff85555545c7596e SHA512 600ec2042e5e6df5e3bbc9fafcaa32255568c35a2a127e4f093ecc9332a799b568002cb414e5c086f24795c4f8f510517bf00c29a9b6a38dd667807d04a18954
diff --git a/dev-python/moto/moto-3.1.13.ebuild b/dev-python/moto/moto-3.1.13.ebuild
new file mode 100644
index 000000000000..d32692d1217f
--- /dev/null
+++ b/dev-python/moto/moto-3.1.13.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Mock library for boto"
+HOMEPAGE="https://github.com/spulec/moto"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-xray-sdk-python-0.93[${PYTHON_USEDEP}]
+ dev-python/boto[${PYTHON_USEDEP}]
+ dev-python/cfn-lint[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-3.3.1[${PYTHON_USEDEP}]
+ dev-python/cookies[${PYTHON_USEDEP}]
+ >=dev-python/docker-py-2.5.1[${PYTHON_USEDEP}]
+ >=dev-python/idna-2.5[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.10.1[${PYTHON_USEDEP}]
+ >=dev-python/jsondiff-1.1.2[${PYTHON_USEDEP}]
+ dev-python/boto3[${PYTHON_USEDEP}]
+ dev-python/botocore[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/flask-cors[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-3.0.7[${PYTHON_USEDEP}]
+ >=dev-python/openapi-spec-validator-0.2.8[${PYTHON_USEDEP}]
+ dev-python/pretty-yaml[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/python-jose[${PYTHON_USEDEP}]
+ dev-python/python-sshpubkeys[${PYTHON_USEDEP}]
+ >=dev-python/responses-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.5[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/zipp[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ >=dev-python/sure-1.4.11[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/test_firehose/test_firehose_put.py::test_put_record_http_destination
+ tests/test_firehose/test_firehose_put.py::test_put_record_batch_http_destination
+ tests/test_swf/responses/test_decision_tasks.py::test_respond_decision_task_completed_with_schedule_activity_task_boto3
+ tests/test_swf/responses/test_timeouts.py::test_activity_task_heartbeat_timeout_boto3
+ tests/test_swf/responses/test_timeouts.py::test_decision_task_start_to_close_timeout_boto3
+ tests/test_swf/responses/test_timeouts.py::test_workflow_execution_start_to_close_timeout_boto3
+ # broken code (local variable used referenced before definition)
+ tests/test_appsync/test_appsync_schema.py
+ # Needs network (or docker?) but not marked as such, bug #807031
+ # TODO: report upstream
+ tests/test_batch/test_batch_jobs.py::test_terminate_job
+ tests/test_batch/test_batch_jobs.py::test_cancel_pending_job
+ tests/test_batch/test_batch_jobs.py::test_cancel_running_job
+ tests/test_batch/test_batch_jobs.py::test_dependencies
+ tests/test_batch/test_batch_jobs.py::test_container_overrides
+ tests/test_cloudformation/test_cloudformation_custom_resources.py::test_create_custom_lambda_resource__verify_cfnresponse_failed
+ tests/test_cloudformation/test_cloudformation_stack_integration.py::test_lambda_function
+ tests/test_events/test_events_lambdatriggers_integration.py::test_creating_bucket__invokes_lambda
+ tests/test_sqs/test_integration.py::test_invoke_function_from_sqs_exception
+ tests/test_sqs/test_sqs_integration.py::test_invoke_function_from_sqs_exception
+ "tests/test_s3/test_s3_lambda_integration.py::test_objectcreated_put__invokes_lambda[match_events0-ObjectCreated:Put]"
+ "tests/test_s3/test_s3_lambda_integration.py::test_objectcreated_put__invokes_lambda[match_events1-ObjectCreated:Put]"
+ "tests/test_s3/test_s3_lambda_integration.py::test_objectcreated_put__invokes_lambda[match_events3-ObjectCreated:Put]"
+ )
+
+ # pytest-django causes freezegun try to mangle stuff inside django
+ # which fails when django is not really used
+ epytest -p no:django -m 'not network'
+}