summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-24 06:07:44 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-24 08:15:28 +0200
commit4c7bb548b76fd7b3caff90c33a66d36303dad341 (patch)
tree46d573ff675ac1950a76f1fdf9ff151745ece6f4 /dev-python/moto
parentdev-python/pydyf: Bump to 0.2.0 (diff)
downloadgentoo-4c7bb548b76fd7b3caff90c33a66d36303dad341.tar.gz
gentoo-4c7bb548b76fd7b3caff90c33a66d36303dad341.tar.bz2
gentoo-4c7bb548b76fd7b3caff90c33a66d36303dad341.zip
dev-python/moto: Bump to 3.1.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/moto')
-rw-r--r--dev-python/moto/Manifest1
-rw-r--r--dev-python/moto/moto-3.1.10.ebuild89
2 files changed, 90 insertions, 0 deletions
diff --git a/dev-python/moto/Manifest b/dev-python/moto/Manifest
index 26ca0a87a171..01ddc2e741ae 100644
--- a/dev-python/moto/Manifest
+++ b/dev-python/moto/Manifest
@@ -1,3 +1,4 @@
+DIST moto-3.1.10.tar.gz 2314423 BLAKE2B ad09f8cb70a1541dce640c870355c349f9a932beec1c98d3d4739bda89e773670fb0209b9ec7aca3a250472d425048d444b08edf2f1555c6777251de14c5a80a SHA512 138e5be59fffcfe4579b6cb292f4f8ec21c5d05723bcd66cae85bcc0f60991ac84310206d5a0fe8361135ff04573173f41b276021981d6f7844a726f18b54f83
DIST moto-3.1.5.tar.gz 2282060 BLAKE2B f7b2cbf1de96b6d96b334e5b51bcdf69fb9645261564b28b290c19c37c27df5c25395ce54cc7d9c424f25cb381f4ddf13dc51456fb7baeec5e21b2da6abf725b SHA512 583c4e76a5acacdcce456cd953109b130dd53d6bf3e50d56d5ead6bfbdcd181109ce3df141686a4717687d3e1e8b33a73bdc7155c36aa5d064a4621e007ab17a
DIST moto-3.1.6.tar.gz 2273226 BLAKE2B 91966fd315b3e5b4904ecc0e17c716bb47ecb6b644ccaad2cd52fb92754b79af0edb11573fadfd40b8ae75c17bad3429b6e2c4801424c4f30fea32689cd790d1 SHA512 f97ca412910ec9a0cf6d7e28b2ff2f2bf6a3d142a091f65eb4ccf8d53ae9d5362cccdbd24d72083f2d9c6200a3f6e400cca32c16965731d0fbd22239f9866d59
DIST moto-3.1.7.tar.gz 2275858 BLAKE2B 7984da8df1ebf305ae11f16179612854b630e20eaeb834d85be4063becf73d0615183c93d242e162c7520225fee9eca149a9756fd507b9aaf8e19242fee3f25e SHA512 fed1c97515bed3640f6959cfba417ed27771d77a1b43e94877520ed582542eb61cc4f7d88c791834425b1a1614641a2c178f57787440af545ecf5b03fd6649f2
diff --git a/dev-python/moto/moto-3.1.10.ebuild b/dev-python/moto/moto-3.1.10.ebuild
new file mode 100644
index 000000000000..990b94d8b951
--- /dev/null
+++ b/dev-python/moto/moto-3.1.10.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Mock library for boto"
+HOMEPAGE="https://github.com/spulec/moto"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/aws-xray-sdk-python-0.93[${PYTHON_USEDEP}]
+ dev-python/boto[${PYTHON_USEDEP}]
+ dev-python/cfn-lint[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-3.3.1[${PYTHON_USEDEP}]
+ dev-python/cookies[${PYTHON_USEDEP}]
+ >=dev-python/docker-py-2.5.1[${PYTHON_USEDEP}]
+ >=dev-python/idna-2.5[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.10.1[${PYTHON_USEDEP}]
+ >=dev-python/jsondiff-1.1.2[${PYTHON_USEDEP}]
+ dev-python/boto3[${PYTHON_USEDEP}]
+ dev-python/botocore[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/flask-cors[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-3.0.7[${PYTHON_USEDEP}]
+ >=dev-python/openapi-spec-validator-0.2.8[${PYTHON_USEDEP}]
+ dev-python/pretty-yaml[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/python-jose[${PYTHON_USEDEP}]
+ dev-python/python-sshpubkeys[${PYTHON_USEDEP}]
+ >=dev-python/responses-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.5[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/zipp[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ >=dev-python/sure-1.4.11[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/test_firehose/test_firehose_put.py::test_put_record_http_destination
+ tests/test_firehose/test_firehose_put.py::test_put_record_batch_http_destination
+ tests/test_swf/responses/test_decision_tasks.py::test_respond_decision_task_completed_with_schedule_activity_task_boto3
+ tests/test_swf/responses/test_timeouts.py::test_activity_task_heartbeat_timeout_boto3
+ tests/test_swf/responses/test_timeouts.py::test_decision_task_start_to_close_timeout_boto3
+ tests/test_swf/responses/test_timeouts.py::test_workflow_execution_start_to_close_timeout_boto3
+ # broken code (local variable used referenced before definition)
+ tests/test_appsync/test_appsync_schema.py
+ # Needs network (or docker?) but not marked as such, bug #807031
+ # TODO: report upstream
+ tests/test_batch/test_batch_jobs.py::test_terminate_job
+ tests/test_batch/test_batch_jobs.py::test_cancel_pending_job
+ tests/test_batch/test_batch_jobs.py::test_cancel_running_job
+ tests/test_batch/test_batch_jobs.py::test_dependencies
+ tests/test_batch/test_batch_jobs.py::test_container_overrides
+ tests/test_cloudformation/test_cloudformation_custom_resources.py::test_create_custom_lambda_resource__verify_cfnresponse_failed
+ tests/test_cloudformation/test_cloudformation_stack_integration.py::test_lambda_function
+ tests/test_sqs/test_integration.py::test_invoke_function_from_sqs_exception
+ tests/test_sqs/test_sqs_integration.py::test_invoke_function_from_sqs_exception
+ "tests/test_s3/test_s3_lambda_integration.py::test_objectcreated_put__invokes_lambda[match_events0-ObjectCreated:Put]"
+ "tests/test_s3/test_s3_lambda_integration.py::test_objectcreated_put__invokes_lambda[match_events1-ObjectCreated:Put]"
+ "tests/test_s3/test_s3_lambda_integration.py::test_objectcreated_put__invokes_lambda[match_events3-ObjectCreated:Put]"
+ )
+
+ # pytest-django causes freezegun try to mangle stuff inside django
+ # which fails when django is not really used
+ epytest -p no:django -m 'not network'
+}