summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-17 00:10:30 +0100
committerSam James <sam@gentoo.org>2021-10-17 00:11:28 +0100
commit7ea378fe491105805a9266c6fdbe8d11d215ae3d (patch)
treeb6fbd0744860ce27aa2550e09cea95aa9f89b804 /dev-python/moto
parentapp-emulation/fs-uae-launcher: Restrict boilerplate tests (diff)
downloadgentoo-7ea378fe491105805a9266c6fdbe8d11d215ae3d.tar.gz
gentoo-7ea378fe491105805a9266c6fdbe8d11d215ae3d.tar.bz2
gentoo-7ea378fe491105805a9266c6fdbe8d11d215ae3d.zip
dev-python/moto: skip network/docker tests
Closes: https://bugs.gentoo.org/807031 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/moto')
-rw-r--r--dev-python/moto/moto-2.2.6.ebuild8
-rw-r--r--dev-python/moto/moto-2.2.9.ebuild8
2 files changed, 16 insertions, 0 deletions
diff --git a/dev-python/moto/moto-2.2.6.ebuild b/dev-python/moto/moto-2.2.6.ebuild
index 349a06d68b97..e8cd22eb118b 100644
--- a/dev-python/moto/moto-2.2.6.ebuild
+++ b/dev-python/moto/moto-2.2.6.ebuild
@@ -65,6 +65,14 @@ python_test() {
# incompatible versions?
tests/test_core/test_decorator_calls.py
tests/test_s3/test_s3_classdecorator.py
+ # Needs network (or docker?) but not marked as such, bug #807031
+ # TODO: report upstream
+ tests/test_batch/test_batch_jobs.py::test_terminate_job
+ tests/test_batch/test_batch_jobs.py::test_cancel_running_job
+ tests/test_batch/test_batch_jobs.py::test_dependencies
+ tests/test_batch/test_batch_jobs.py::test_container_overrides
+ tests/test_sqs/test_integration.py::test_invoke_function_from_sqs_exception
+ tests/test_sqs/test_sqs_integration.py::test_invoke_function_from_sqs_exception
)
# pytest-django causes freezegun try to mangle stuff inside django
diff --git a/dev-python/moto/moto-2.2.9.ebuild b/dev-python/moto/moto-2.2.9.ebuild
index 2cb72d74530a..90b1a6e1227e 100644
--- a/dev-python/moto/moto-2.2.9.ebuild
+++ b/dev-python/moto/moto-2.2.9.ebuild
@@ -69,6 +69,14 @@ python_test() {
tests/test_swf/responses/test_timeouts.py::test_activity_task_heartbeat_timeout_boto3
tests/test_swf/responses/test_timeouts.py::test_decision_task_start_to_close_timeout_boto3
tests/test_swf/responses/test_timeouts.py::test_workflow_execution_start_to_close_timeout_boto3
+ # Needs network (or docker?) but not marked as such, bug #807031
+ # TODO: report upstream
+ tests/test_batch/test_batch_jobs.py::test_terminate_job
+ tests/test_batch/test_batch_jobs.py::test_cancel_running_job
+ tests/test_batch/test_batch_jobs.py::test_dependencies
+ tests/test_batch/test_batch_jobs.py::test_container_overrides
+ tests/test_sqs/test_integration.py::test_invoke_function_from_sqs_exception
+ tests/test_sqs/test_sqs_integration.py::test_invoke_function_from_sqs_exception
)
# pytest-django causes freezegun try to mangle stuff inside django