summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <horea.christ@yandex.com>2016-09-03 01:27:02 +0200
committerDavid Seifert <soap@gentoo.org>2016-09-05 23:10:07 +0200
commit1ce8d44e7a97943600b7ea27791f06367b56a3c2 (patch)
tree49a4718f986b4be66506b9d26db4bed5d13c25a4 /dev-python/moviepy/moviepy-0.2.2.ebuild
parentdev-python/traits: updated python compatibility and EAPI of testing package (diff)
downloadgentoo-1ce8d44e7a97943600b7ea27791f06367b56a3c2.tar.gz
gentoo-1ce8d44e7a97943600b7ea27791f06367b56a3c2.tar.bz2
gentoo-1ce8d44e7a97943600b7ea27791f06367b56a3c2.zip
dev-python/moviepy: new ebuild
Package-Manager: portage-2.3.0 Closes: https://github.com/gentoo/gentoo/pull/2206 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/moviepy/moviepy-0.2.2.ebuild')
-rw-r--r--dev-python/moviepy/moviepy-0.2.2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/moviepy/moviepy-0.2.2.ebuild b/dev-python/moviepy/moviepy-0.2.2.ebuild
new file mode 100644
index 000000000000..6cd0e12ae6ae
--- /dev/null
+++ b/dev-python/moviepy/moviepy-0.2.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Video editing with Python"
+HOMEPAGE="http://zulko.github.io/moviepy/"
+SRC_URI="https://github.com/Zulko/moviepy/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+ "
+RDEPEND="
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/imageio[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pygame[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ virtual/ffmpeg
+ "
+
+python_test() {
+ py.test --verbose || die
+}