summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-07-01 22:35:12 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-07-01 23:15:26 +0200
commit991e3fb9d306af3b78241c60bdec455532a9affe (patch)
tree118f589e85e44f5e3e7dbd3b13332ab406cfa95c /dev-python/mpdlcd
parentdev-python/consonance: add python3.10 support (diff)
downloadgentoo-991e3fb9d306af3b78241c60bdec455532a9affe.tar.gz
gentoo-991e3fb9d306af3b78241c60bdec455532a9affe.tar.bz2
gentoo-991e3fb9d306af3b78241c60bdec455532a9affe.zip
dev-python/mpdlcd: add python3.10 support
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-python/mpdlcd')
-rw-r--r--dev-python/mpdlcd/mpdlcd-0.5.2.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/dev-python/mpdlcd/mpdlcd-0.5.2.ebuild b/dev-python/mpdlcd/mpdlcd-0.5.2.ebuild
index 62b00006e881..5bc7994d2cb5 100644
--- a/dev-python/mpdlcd/mpdlcd-0.5.2.ebuild
+++ b/dev-python/mpdlcd/mpdlcd-0.5.2.ebuild
@@ -1,15 +1,16 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="A small tool to display the MPD status on a LCDproc server."
HOMEPAGE="https://github.com/rbarrois/mpdlcd"
SRC_URI="https://github.com/rbarrois/${PN}/archive/${P}.tar.gz"
+S="${WORKDIR}/${PN}-${P}"
LICENSE="BSD"
SLOT="0"
@@ -17,8 +18,6 @@ KEYWORDS="amd64 x86"
RDEPEND="dev-python/python-mpd"
-S="${WORKDIR}/${PN}-${P}"
-
distutils_enable_tests pytest
python_install_all() {