summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-03 14:48:41 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-03 17:41:35 +0300
commit97973bebc1ca33be91e233bd055343ea82190d89 (patch)
treeed0600f0de44355672f22e492a81e274cd4b0cf4 /dev-python/mpmath
parentdev-python/mpmath: reformat metadata.xml (diff)
downloadgentoo-97973bebc1ca33be91e233bd055343ea82190d89.tar.gz
gentoo-97973bebc1ca33be91e233bd055343ea82190d89.tar.bz2
gentoo-97973bebc1ca33be91e233bd055343ea82190d89.zip
dev-python/mpmath: enable py3.10
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/mpmath')
-rw-r--r--dev-python/mpmath/mpmath-1.2.1.ebuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/dev-python/mpmath/mpmath-1.2.1.ebuild b/dev-python/mpmath/mpmath-1.2.1.ebuild
index 7960b10143a9..38db5821fca7 100644
--- a/dev-python/mpmath/mpmath-1.2.1.ebuild
+++ b/dev-python/mpmath/mpmath-1.2.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1 virtualx
@@ -14,8 +14,7 @@ SRC_URI="https://github.com/fredrik-johansson/${PN}/archive/${PV}.tar.gz -> ${P}
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
-IUSE="gmp matplotlib test"
-RESTRICT="!test? ( test )"
+IUSE="gmp matplotlib"
RDEPEND="
gmp? ( dev-python/gmpy[${PYTHON_USEDEP}] )
@@ -27,6 +26,7 @@ distutils_enable_tests pytest
src_configure() {
export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+ distutils-r1_src_configure
}
src_test() {
@@ -34,7 +34,5 @@ src_test() {
}
python_test() {
- pushd ${PN}/tests >/dev/null
- ${EPYTHON} runtests.py -local || die "Tests failed with ${EPYTHON}"
- popd >/dev/null
+ "${EPYTHON}" mpmath/tests/runtests.py -local || die "Tests failed with ${EPYTHON}"
}