summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-02-15 23:55:28 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2018-02-15 23:55:28 -0600
commit4f892bed74a8d0a86ea78e8cc088125d5f73cca3 (patch)
tree6647be00c44106cfc154ea7644a0d360af7ef70e /dev-python/msgpack
parentdev-python/oslo-utils: 3.35.0 bup (diff)
downloadgentoo-4f892bed74a8d0a86ea78e8cc088125d5f73cca3.tar.gz
gentoo-4f892bed74a8d0a86ea78e8cc088125d5f73cca3.tar.bz2
gentoo-4f892bed74a8d0a86ea78e8cc088125d5f73cca3.zip
dev-python/msgpack: 0.5.1 bup
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-python/msgpack')
-rw-r--r--dev-python/msgpack/Manifest1
-rw-r--r--dev-python/msgpack/msgpack-0.5.1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/msgpack/Manifest b/dev-python/msgpack/Manifest
index 10f17ad45891..2777e70f82b6 100644
--- a/dev-python/msgpack/Manifest
+++ b/dev-python/msgpack/Manifest
@@ -1 +1,2 @@
DIST msgpack-python-0.4.8.tar.gz 113641 BLAKE2B d22efe13302e28d0701b95b2dc4cf4792f9e045efdf77b31ac5c6170b503c885c265ff63387fe76a1aa67b1624963aa26d76dffb15fc2cb10cfe672b59e71b99 SHA512 59e9c43be6b92e6d10f40999e0902c350137e67a83c43bb15b273eca856a6eb39f24b625b02b40188a9365ce3101f03bfa9aa3dfff56c5c3b551533942183481
+DIST msgpack-python-0.5.1.tar.gz 138953 BLAKE2B 1fb7e5be33992808319e1444ff7f84cc13f034e60ce0ef2f72161bd4ccd0cd1ede27382bc1f365f268557c8ffe503fd12de66eb5840e79760d818e7e2f67fdcd SHA512 e5172e20bb25d2e12ba34ad2805ba4ea0776397986e8bf8e26d21353f57a2dba59a9c6669c817e4e91d5801558a50f95d81e02343f8f0292a01ec5d822fba61c
diff --git a/dev-python/msgpack/msgpack-0.5.1.ebuild b/dev-python/msgpack/msgpack-0.5.1.ebuild
new file mode 100644
index 000000000000..2fbeb83213b5
--- /dev/null
+++ b/dev-python/msgpack/msgpack-0.5.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+MY_PN="${PN}-python"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="MessagePack (de)serializer for Python"
+HOMEPAGE="http://msgpack.org https://github.com/msgpack/msgpack-python/ https://pypi.python.org/pypi/msgpack-python/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+S=${WORKDIR}/${MY_P}
+
+python_test() {
+ py.test test || die "Tests fail with ${EPYTHON}"
+}