summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2016-07-30 10:11:32 -0500
committerAlex Brandt <alunduil@gentoo.org>2016-07-30 10:11:32 -0500
commitc32caf73551c8f6ee260ba5d68885b2cebb46b21 (patch)
tree337380814fafc8c108212c3db76cf1f5090ac693 /dev-python/multidict/multidict-1.3.0_alpha1.ebuild
parentdev-python/botocore: remove version 1.4.31 (diff)
downloadgentoo-c32caf73551c8f6ee260ba5d68885b2cebb46b21.tar.gz
gentoo-c32caf73551c8f6ee260ba5d68885b2cebb46b21.tar.bz2
gentoo-c32caf73551c8f6ee260ba5d68885b2cebb46b21.zip
dev-python/multidict: add version 1.3.0_alpha1
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/multidict/multidict-1.3.0_alpha1.ebuild')
-rw-r--r--dev-python/multidict/multidict-1.3.0_alpha1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/multidict/multidict-1.3.0_alpha1.ebuild b/dev-python/multidict/multidict-1.3.0_alpha1.ebuild
new file mode 100644
index 000000000000..41a9fda0c86b
--- /dev/null
+++ b/dev-python/multidict/multidict-1.3.0_alpha1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python3_4 python3_5 )
+
+inherit distutils-r1 vcs-snapshot
+
+MY_PV="${PV//_alpha/a}"
+
+DESCRIPTION="multidict implementation"
+HOMEPAGE="https://github.com/aio-libs/multidict/"
+SRC_URI="https://github.com/aio-libs/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+RDEPEND=""
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ "${PYTHON}" -m pytest tests || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}