summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-11-21 18:03:26 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-11-21 19:15:15 -0800
commit327a1a4ad4a35ce5e36c688cddfdf7accf162876 (patch)
treea790f29d67a9fd1a8fd0f72425a80d8edfd911bd /dev-python/munch/files
parentdev-python/psutil: Version bump to 5.6.5, add py38, enable tests (diff)
downloadgentoo-327a1a4ad4a35ce5e36c688cddfdf7accf162876.tar.gz
gentoo-327a1a4ad4a35ce5e36c688cddfdf7accf162876.tar.bz2
gentoo-327a1a4ad4a35ce5e36c688cddfdf7accf162876.zip
dev-python/munch: Version bump to 2.5.0, add py38
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/munch/files')
-rw-r--r--dev-python/munch/files/munch-2.5.0-pbrectomy.patch17
-rw-r--r--dev-python/munch/files/munch-2.5.0-revert-pbr.patch39
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/munch/files/munch-2.5.0-pbrectomy.patch b/dev-python/munch/files/munch-2.5.0-pbrectomy.patch
new file mode 100644
index 000000000000..13121c345b80
--- /dev/null
+++ b/dev-python/munch/files/munch-2.5.0-pbrectomy.patch
@@ -0,0 +1,17 @@
+diff --git a/setup.py b/setup.py
+index 31f229c..62e1ad6 100644
+--- a/setup.py
++++ b/setup.py
+@@ -1,9 +1,7 @@
+-from setuptools import setup
++from setuptools import setup, find_packages
+
+
+ setup(
+- setup_requires=['pbr>=3.0', 'setuptools>=17.1'],
+- pbr=True,
+- long_description_content_type='text/markdown; charset=UTF-8',
+- keywords=['munch', 'dict', 'mapping', 'container', 'collection'],
++ find_packages(exclude=['tests']),
++ version="%VERSION%"
+ )
diff --git a/dev-python/munch/files/munch-2.5.0-revert-pbr.patch b/dev-python/munch/files/munch-2.5.0-revert-pbr.patch
new file mode 100644
index 000000000000..450020cc2c19
--- /dev/null
+++ b/dev-python/munch/files/munch-2.5.0-revert-pbr.patch
@@ -0,0 +1,39 @@
+diff --git a/setup.py b/setup.py
+index 31f229c..9046e38 100644
+--- a/setup.py
++++ b/setup.py
+@@ -1,9 +1,29 @@
+-from setuptools import setup
+-
++from setuptools import setup, find_packages
+
+ setup(
+- setup_requires=['pbr>=3.0', 'setuptools>=17.1'],
+- pbr=True,
+- long_description_content_type='text/markdown; charset=UTF-8',
++ name="munch",
++ version=__version__,
++ description="A dot-accessible dictionary (a la JavaScript objects).",
++ url="http://github.com/Infinidat/munch",
++ author="Rotem Yaari",
++ author_email="vmalloc@gmail.com",
++ install_requires=[
++ 'six',
++ ],
++ packages=find_packages(exclude=["tests"]),
+ keywords=['munch', 'dict', 'mapping', 'container', 'collection'],
++ classifiers=[
++ 'Development Status :: 5 - Production/Stable',
++ 'Intended Audience :: Developers',
++ 'Operating System :: OS Independent',
++ 'Programming Language :: Python',
++ "Programming Language :: Python :: 2.7",
++ "Programming Language :: Python :: 3.5",
++ "Programming Language :: Python :: 3.6",
++ 'Topic :: Software Development',
++ 'Topic :: Software Development :: Libraries',
++ 'Topic :: Utilities',
++ 'License :: OSI Approved :: MIT License',
++ ],
++ license='MIT',
+ )