summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-10 16:47:24 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-10 17:43:26 -0500
commit5b6ddcafbbbbdf89a17f4aa041d4dee967d18270 (patch)
tree533c52c5b1b8bd813709eb18c2de737b3153538f /dev-python/munch/munch-2.3.2.ebuild
parentdev-python/python-barbicanclient: 4.8.1 bump (diff)
downloadgentoo-5b6ddcafbbbbdf89a17f4aa041d4dee967d18270.tar.gz
gentoo-5b6ddcafbbbbdf89a17f4aa041d4dee967d18270.tar.bz2
gentoo-5b6ddcafbbbbdf89a17f4aa041d4dee967d18270.zip
dev-python/munch: 2.3.2 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/munch/munch-2.3.2.ebuild')
-rw-r--r--dev-python/munch/munch-2.3.2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/munch/munch-2.3.2.ebuild b/dev-python/munch/munch-2.3.2.ebuild
new file mode 100644
index 000000000000..1820af62ddd5
--- /dev/null
+++ b/dev-python/munch/munch-2.3.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_{5,6,7},3_{3,4,5,6,7}} )
+
+inherit distutils-r1
+
+DESCRIPTION="A dot-accessible dictionary (a la JavaScript objects)"
+HOMEPAGE="https://github.com/Infinidat/munch"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm64 ~x86"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"