summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2016-05-22 12:16:31 -0500
committerAlex Brandt <alunduil@gentoo.org>2016-05-22 12:16:31 -0500
commit402f554dcfaf98e7b1272449e1b552f51dd316b4 (patch)
treed13d7d53d2b599bc883b7f1e72c098af4ac0ff08 /dev-python/mypy
parentsys-fs/ext4magic: update maintainer email and remove proxy-maint (diff)
downloadgentoo-402f554dcfaf98e7b1272449e1b552f51dd316b4.tar.gz
gentoo-402f554dcfaf98e7b1272449e1b552f51dd316b4.tar.bz2
gentoo-402f554dcfaf98e7b1272449e1b552f51dd316b4.zip
dev-python/mypy: add version 0.4.1
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'dev-python/mypy')
-rw-r--r--dev-python/mypy/Manifest1
-rw-r--r--dev-python/mypy/mypy-0.4.1.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/mypy/Manifest b/dev-python/mypy/Manifest
index 7a82e9c33420..3e0fd8778cb4 100644
--- a/dev-python/mypy/Manifest
+++ b/dev-python/mypy/Manifest
@@ -1 +1,2 @@
DIST mypy-0.2.0.tar.gz 626604 SHA256 0c24f50509bdf3e0d9bd386a08ef4f11ee0114e1f5a9b2afeacbf9561cf022c1 SHA512 b03014abf152407c7629dba925aca6178fcdf57532f47c728edcb591a56942cda13e02122f405aa269e9b6303de1f4a9d5cbb2d5a5af6e90a808a3db94cca53f WHIRLPOOL 7d9f05ead0bfea78bdf228b0bb7c3519e8eaa70f52c00049963780f42e71e9f44168edb09d2e558f59b07a4d09912d1d6d3c8b11a2b9e47db77b2c06e56eb910
+DIST mypy-0.4.1.tar.gz 682081 SHA256 37e94e528078fff782bfbe36c0e9cbd2ff40aa436eb335c2c75d006136aee3e7 SHA512 fafe93ba5e5989be5ebe966c9b8ca3ff899101b56407d5167ef42173374aae5f8ebf5631e573b5d45b845fe2b17488834c72e2483e68abf4992a39188ffa50a1 WHIRLPOOL 5b2f2d5d6fe00ccad93824476e55f673c9ecc8bc38b0aa2f3ce2f25850a9dca17b8bb91ad537801a6ecc0bc2ac0210282bcbd755e6c0a96cd9f8b647530cc093
diff --git a/dev-python/mypy/mypy-0.4.1.ebuild b/dev-python/mypy/mypy-0.4.1.ebuild
new file mode 100644
index 000000000000..38f9f5e4ca31
--- /dev/null
+++ b/dev-python/mypy/mypy-0.4.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python3_3 python3_4 python3_5 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Optional static typing for Python"
+HOMEPAGE="http://www.mypy-lang.org/"
+SRC_URI="https://github.com/JukkaL/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc examples test"
+
+DEPEND="
+ test? ( dev-python/flake8[${PYTHON_USEDEP}] )
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="$(python_gen_cond_dep 'dev-python/typing[${PYTHON_USEDEP}]' 'python3_3' 'python3_4')"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ local PYTHONPATH="$(pwd)"
+
+ "${PYTHON}" runtests.py || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ use examples && local EXAMPLES=( samples/. )
+
+ distutils-r1_python_install_all
+}