summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-24 17:21:47 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-24 17:45:57 +0200
commitb6d260fdd302c24cb3b06149f4cc03715d77cfaa (patch)
treee22c6ecacf604c860d93f3ed8818e486c0c44ac9 /dev-python/myst_parser
parentdev-python/mdit-py-plugins: Enable pypy3 (diff)
downloadgentoo-b6d260fdd302c24cb3b06149f4cc03715d77cfaa.tar.gz
gentoo-b6d260fdd302c24cb3b06149f4cc03715d77cfaa.tar.bz2
gentoo-b6d260fdd302c24cb3b06149f4cc03715d77cfaa.zip
dev-python/myst_parser: Enable pypy3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/myst_parser')
-rw-r--r--dev-python/myst_parser/myst_parser-0.18.0.ebuild23
1 files changed, 16 insertions, 7 deletions
diff --git a/dev-python/myst_parser/myst_parser-0.18.0.ebuild b/dev-python/myst_parser/myst_parser-0.18.0.ebuild
index 607aca9eec4a..bc0af0f8d333 100644
--- a/dev-python/myst_parser/myst_parser-0.18.0.ebuild
+++ b/dev-python/myst_parser/myst_parser-0.18.0.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=flit
-PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
inherit distutils-r1
@@ -43,10 +43,19 @@ BDEPEND="
)
"
-EPYTEST_DESELECT=(
- # Unimportant tests needing a new dep linkify
- tests/test_renderers/test_myst_config.py::test_cmdline
- tests/test_sphinx/test_sphinx_builds.py::test_extended_syntaxes
-)
-
distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Unimportant tests needing a new dep linkify
+ tests/test_renderers/test_myst_config.py::test_cmdline
+ tests/test_sphinx/test_sphinx_builds.py::test_extended_syntaxes
+ )
+
+ [[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
+ # bad test relying on exact exception messages
+ "tests/test_renderers/test_include_directive.py::test_errors[9-Non-existent path:]"
+ )
+
+ epytest
+}