summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-03 07:25:08 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-03 07:42:56 +0100
commit4f76c309c1b3f2ce9ca71a9fe928d79925f3ef90 (patch)
tree2994b0c7a877a73fd2c71fdb4f2600127fc8afdc /dev-python/natsort/natsort-7.2.0.ebuild
parentx11-terms/kitty: drop 0.20.1, 0.20.3, 0.21.2 (diff)
downloadgentoo-4f76c309c1b3f2ce9ca71a9fe928d79925f3ef90.tar.gz
gentoo-4f76c309c1b3f2ce9ca71a9fe928d79925f3ef90.tar.bz2
gentoo-4f76c309c1b3f2ce9ca71a9fe928d79925f3ef90.zip
dev-python/natsort: Bump to 7.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/natsort/natsort-7.2.0.ebuild')
-rw-r--r--dev-python/natsort/natsort-7.2.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/natsort/natsort-7.2.0.ebuild b/dev-python/natsort/natsort-7.2.0.ebuild
new file mode 100644
index 000000000000..59e2abfb948a
--- /dev/null
+++ b/dev-python/natsort/natsort-7.2.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Natural sorting for Python"
+HOMEPAGE="https://pypi.org/project/natsort/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest