summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-20 10:10:37 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-20 10:16:45 +0200
commit18f79d2f10a5685d3bc2779b328961866e49f3fe (patch)
tree675e1123407b3c49e1eb3c0372bf9998d28cad2a /dev-python/nautilus-python/nautilus-python-1.2.3-r1.ebuild
parentpackage.mask: Last rite gnome-base/libgnome-keyring (diff)
downloadgentoo-18f79d2f10a5685d3bc2779b328961866e49f3fe.tar.gz
gentoo-18f79d2f10a5685d3bc2779b328961866e49f3fe.tar.bz2
gentoo-18f79d2f10a5685d3bc2779b328961866e49f3fe.zip
dev-python/nautilus-python: Remove python2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/nautilus-python/nautilus-python-1.2.3-r1.ebuild')
-rw-r--r--dev-python/nautilus-python/nautilus-python-1.2.3-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/nautilus-python/nautilus-python-1.2.3-r1.ebuild b/dev-python/nautilus-python/nautilus-python-1.2.3-r1.ebuild
new file mode 100644
index 000000000000..23826a711942
--- /dev/null
+++ b/dev-python/nautilus-python/nautilus-python-1.2.3-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="Python bindings for the Nautilus file manager"
+HOMEPAGE="https://projects.gnome.org/nautilus-python/"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm64 x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# Require pygobject:3 and USE=introspection on nautilus for sanity,
+# because no (user) plugins could work without them; configure itself
+# requires pygobject:3 or :2 and >=nautilus-2.32
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
+ ')
+ >=gnome-base/nautilus-3[introspection]
+ ${PYTHON_DEPS}
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.14
+ virtual/pkgconfig
+"
+
+# https://gitlab.gnome.org/GNOME/nautilus-python/-/merge_requests/7
+PATCHES=( "${FILESDIR}"/${P}-gcc10-fnocommon.patch )
+
+src_install() {
+ gnome2_src_install
+ # Directory for systemwide extensions
+ keepdir /usr/share/nautilus-python/extensions
+}