summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Licht <jonas.licht@fem.tu-ilmenau.de>2020-02-18 23:03:11 +0100
committerMatt Turner <mattst88@gentoo.org>2020-06-03 20:11:49 -0700
commitd66b9aa3c6a7c886962e2a39b40941d6e7c63866 (patch)
treef844b89241a070cbafe3741733bebd63aaf70414 /dev-python/nautilus-python/nautilus-python-1.2.3.ebuild
parentapp-backup/snapper: fix the missing dependency (diff)
downloadgentoo-d66b9aa3c6a7c886962e2a39b40941d6e7c63866.tar.gz
gentoo-d66b9aa3c6a7c886962e2a39b40941d6e7c63866.tar.bz2
gentoo-d66b9aa3c6a7c886962e2a39b40941d6e7c63866.zip
dev-python/nautilus-python: Version bump to 1.2.3
and add python3 target Closes: https://bugs.gentoo.org/673038 Closes: https://github.com/gentoo/gentoo/pull/14696 Signed-off-by: Jonas Licht <jonas.licht@fem.tu-ilmenau.de> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-python/nautilus-python/nautilus-python-1.2.3.ebuild')
-rw-r--r--dev-python/nautilus-python/nautilus-python-1.2.3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/nautilus-python/nautilus-python-1.2.3.ebuild b/dev-python/nautilus-python/nautilus-python-1.2.3.ebuild
new file mode 100644
index 000000000000..8f8557f2af2e
--- /dev/null
+++ b/dev-python/nautilus-python/nautilus-python-1.2.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python{2_7,3_{6,7,8}} )
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="Python bindings for the Nautilus file manager"
+HOMEPAGE="https://projects.gnome.org/nautilus-python/"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# Require pygobject:3 and USE=introspection on nautilus for sanity,
+# because no (user) plugins could work without them; configure itself
+# requires pygobject:3 or :2 and >=nautilus-2.32
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
+ ')
+ >=gnome-base/nautilus-3[introspection]
+ ${PYTHON_DEPS}
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.14
+ virtual/pkgconfig
+"
+
+src_install() {
+ gnome2_src_install
+ # Directory for systemwide extensions
+ keepdir /usr/share/nautilus-python/extensions
+}