summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-12 08:58:03 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-12 09:36:14 +0100
commitdb606a97c95910373df107f6369eb49f7b4438ed (patch)
treea28bc178bce06e913deaf7a2e7964eff2420dfad /dev-python/nbclassic
parentapp-admin/awscli: Bump to 1.22.33 (diff)
downloadgentoo-db606a97c95910373df107f6369eb49f7b4438ed.tar.gz
gentoo-db606a97c95910373df107f6369eb49f7b4438ed.tar.bz2
gentoo-db606a97c95910373df107f6369eb49f7b4438ed.zip
dev-python/nbclassic: Bump to 0.3.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/nbclassic')
-rw-r--r--dev-python/nbclassic/Manifest1
-rw-r--r--dev-python/nbclassic/nbclassic-0.3.5.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/nbclassic/Manifest b/dev-python/nbclassic/Manifest
index 0baa70ee5d41..3507c7f03168 100644
--- a/dev-python/nbclassic/Manifest
+++ b/dev-python/nbclassic/Manifest
@@ -1,2 +1,3 @@
DIST nbclassic-0.3.3.tar.gz 21924 BLAKE2B 382d41c2eeb6ffc9588b80c0bc84e7e8b581fc36f2628d46577ca0a6956c50086a7b9a3bccb1c318fc60169a0367c8c5e1c6bba56b0a35fa063768f8fa580d52 SHA512 74b765c842351b2a93e92850193db7d3ef1a0b11c0c25a9adb2d1b8f7a6f88ae083cc700cda004d874340443632e738a24d26349d661613a707ad6cc42abd709
DIST nbclassic-0.3.4.tar.gz 22308 BLAKE2B e5adddbd89f22ea1391149d97484f34c3f4d1a7601e471859834a06f5294868bbb23e96a536e792599f5743b68cb72bb91c88ba1e79d4fb4dc0f1ad6ee78041f SHA512 fe18a3523f7cf6bb411fe2e78f6bd0313e18a8a63a51649c99bdfc11365e2d775b8e6b879da1326c5389ab1a69e52a267cafa905348fead74b24a1d5d65e8646
+DIST nbclassic-0.3.5.tar.gz 22668 BLAKE2B d7e74e1274294e9d0d8888d0ccb2718fd02d73eca22d29b3b944a1886f4b7dfd8c7ee893239856790f0b7e84e3c9102c27fa12cd06be8a4015b0197e3516d41a SHA512 a3b5b0b4f11be93adee4f8669127de0b1a5c9d38fedefbb924b7b446db9f0e7e0987b17f62f7d831d7a2dd87de605a2300973735a4d2b8cefbbcbab8403a3d1c
diff --git a/dev-python/nbclassic/nbclassic-0.3.5.ebuild b/dev-python/nbclassic/nbclassic-0.3.5.ebuild
new file mode 100644
index 000000000000..07ca7eea2bc7
--- /dev/null
+++ b/dev-python/nbclassic/nbclassic-0.3.5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter Notebook as a Jupyter Server Extension"
+HOMEPAGE="https://jupyter.org/"
+SRC_URI="https://github.com/jupyterlab/nbclassic/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/jupyter_server[${PYTHON_USEDEP}]
+ <dev-python/notebook-7[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
+ dev-python/pytest-tornasync[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Defining 'pytest_plugins' in a non-top-level conftest is no longer supported:
+ mv ${PN}/conftest.py . || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ # move /usr/etc stuff to /etc
+ mv "${ED}/usr/etc" "${ED}/etc" || die
+}